New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Warning "io/console not supported; tty will not be manipulated" occurs again on 1.7.23 #3550

Closed
rovf opened this Issue Dec 19, 2015 · 8 comments

Comments

Projects
None yet
6 participants
@rovf

rovf commented Dec 19, 2015

Using: jruby 1.7.23 (1.9.3p551) 2015-11-24 f496dd5 on Java HotSpot(TM) 64-Bit Server VM 1.7.0_79-b15 +jit [Windows 7-amd64]

A related issue, #1614, was closed on the grounds, that it was finally fixed (for Windows).

At least in JRuby 1.7.23, installed from

https://s3.amazonaws.com/jruby.org/downloads/1.7.23/jruby_windows_x64_1_7_23.exe

the warning still occurs, when I do a

jruby -c FILENAME

@kares kares added this to the JRuby 1.7.24 milestone Jan 11, 2016

@rjattrill

This comment has been minimized.

Show comment
Hide comment
@rjattrill

rjattrill Jan 11, 2016

Yes - I observe this with 1.7.22 on Windows but not 1.7.16.1

C:\Users\rattrill>jruby -v
jruby 1.7.22 (1.9.3p551) 2015-08-20 c28f492 on Java HotSpot(TM) 64-Bit Server VM 1.7.0_79-b15 +jit [Windows 7-amd64]

C:\opt\jruby-1.7.16.1\bin>jruby -v
jruby 1.7.16.1 (1.9.3p392) 2014-10-28 4e93f31 on Java HotSpot(TM) 64-Bit Server VM 1.7.0_79-b15 +jit [Windows 7-amd64]

rjattrill commented Jan 11, 2016

Yes - I observe this with 1.7.22 on Windows but not 1.7.16.1

C:\Users\rattrill>jruby -v
jruby 1.7.22 (1.9.3p551) 2015-08-20 c28f492 on Java HotSpot(TM) 64-Bit Server VM 1.7.0_79-b15 +jit [Windows 7-amd64]

C:\opt\jruby-1.7.16.1\bin>jruby -v
jruby 1.7.16.1 (1.9.3p392) 2014-10-28 4e93f31 on Java HotSpot(TM) 64-Bit Server VM 1.7.0_79-b15 +jit [Windows 7-amd64]

enebo added a commit that referenced this issue Jan 13, 2016

@enebo enebo closed this Jan 13, 2016

kares added a commit that referenced this issue Jan 20, 2016

Merge branch 'jruby-1_7'
* jruby-1_7: (27 commits)
  Update jnr-posix to finally fix 32 bit JVM crasher on windows stat
  pend marshaling behavior - not working for Java non-member classes (GH-3526)
  local (non-member) classes should have correct name just like anonymous classes
  DRY out getClassFromPath usage in UnmarshalStream (all delegating to one method)
  review runtime's getClassFromPath
  hide unmarshalObject methods that use private inner type as a parameter
  Update for newer jnr-posix for windows 32 bit JVM stat workaround
  Remove remaining `should` uses from compiler specs.
  Don't deoptimize while loops just because of a block arg.
  Always assign masgn destructured args in block as block-local.
  Move parser scripts to tool.
  Add case for breakage fixed in b93fbb6.
  Check for empty identifiers and treat them as false.
  Same fix for AOT as for interp for #3180.
  Also use the anonymous wrap class for pushRubyClass, for defs.
  More robust, less breaky fix to omit bad class/package elements.
  Revert "Use methods instead of procs for converters."
  Fixes #3550. Warning "io/console not supported; tty will not be manipulated" occurs again on 1.7.23
  updating to jcodings messes with this obscure char no longer being considered a space.
  Update to latest jcodings
  ...
@psuzzi

This comment has been minimized.

Show comment
Hide comment
@psuzzi

psuzzi Jan 17, 2017

I get the same error in Windows 10, with ruby 2.3.3 (64bit)

ruby 2.3.3p222 (2016-11-21 revision 56859) [x64-mingw32]

psuzzi commented Jan 17, 2017

I get the same error in Windows 10, with ruby 2.3.3 (64bit)

ruby 2.3.3p222 (2016-11-21 revision 56859) [x64-mingw32]

@kares

This comment has been minimized.

Show comment
Hide comment
@kares

kares Jan 17, 2017

Member

@psuzzi well we can't do much about that on JRuby's end :) ... report with Ruby!

Member

kares commented Jan 17, 2017

@psuzzi well we can't do much about that on JRuby's end :) ... report with Ruby!

@enebo

This comment has been minimized.

Show comment
Hide comment
@enebo

enebo Jan 17, 2017

Member

@kares I think he might be saying we match MRI behavior?

Member

enebo commented Jan 17, 2017

@kares I think he might be saying we match MRI behavior?

@psuzzi

This comment has been minimized.

Show comment
Hide comment
@psuzzi

psuzzi Jan 17, 2017

Sorry, my bad. This IS about JRuby, but I wrongly reported the version of ruby.

Here you can see a pastebin for the error: http://pastebin.com/Di6V9hAK

psuzzi commented Jan 17, 2017

Sorry, my bad. This IS about JRuby, but I wrongly reported the version of ruby.

Here you can see a pastebin for the error: http://pastebin.com/Di6V9hAK

@kares

This comment has been minimized.

Show comment
Hide comment
@kares

kares Jan 18, 2017

Member

and what would the version of JRuby (used by Gradle's asciidoctor) be than :) ? if you have any hints ...

Member

kares commented Jan 18, 2017

and what would the version of JRuby (used by Gradle's asciidoctor) be than :) ? if you have any hints ...

@fapdash

This comment has been minimized.

Show comment
Hide comment
@fapdash

fapdash Jan 18, 2017

From my understanding, gradle asciidoctor plugin uses asciidoctorj.
Newest version of asciidoctorj (1.5.4) uses jruby 1.7.26.
https://github.com/asciidoctor/asciidoctorj/blob/master/build.gradle#L37

But the gradle plugin is using asciidoctorj 1.5.3.2
https://github.com/asciidoctor/asciidoctor-gradle-plugin/blob/development/build.gradle#L48
It seems like they ended up using jruby 1.7.21 for this version?
asciidoctor/asciidoctorj#401
asciidoctor/asciidoctorj@38c92b9

fapdash commented Jan 18, 2017

From my understanding, gradle asciidoctor plugin uses asciidoctorj.
Newest version of asciidoctorj (1.5.4) uses jruby 1.7.26.
https://github.com/asciidoctor/asciidoctorj/blob/master/build.gradle#L37

But the gradle plugin is using asciidoctorj 1.5.3.2
https://github.com/asciidoctor/asciidoctor-gradle-plugin/blob/development/build.gradle#L48
It seems like they ended up using jruby 1.7.21 for this version?
asciidoctor/asciidoctorj#401
asciidoctor/asciidoctorj@38c92b9

@kares

This comment has been minimized.

Show comment
Hide comment
@kares

kares Jan 18, 2017

Member

thanks @fap- ... @psuzzi please try the latest version (which should be 1.5.4) as this has been resolved around 1.7.24 thus 1.5.3 might not have the desired JRuby version (and would still warn) !

Member

kares commented Jan 18, 2017

thanks @fap- ... @psuzzi please try the latest version (which should be 1.5.4) as this has been resolved around 1.7.24 thus 1.5.3 might not have the desired JRuby version (and would still warn) !

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment