New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

MRI tests that do not appear to exist for MRI #4284

Closed
headius opened this Issue Nov 14, 2016 · 0 comments

Comments

Projects
None yet
1 participant
@headius
Member

headius commented Nov 14, 2016

There appears to be a number of files and dirs in JRuby master's MRI tests versus Ruby 2.3.1 tests:

[] ~/projects/jruby-ruby $ git st test
On branch jruby-ruby_2_3_1
Your branch is up-to-date with 'origin/jruby-ruby_2_3_1'.
Untracked files:
  (use "git add <file>..." to include in what will be committed)

	test/-ext-/old_thread_select/
	test/-ext-/test_bug-3662.rb
	test/dl/
	test/excludes_truffle/
	test/inlinetest.rb
	test/minitest/test_minitest_spec.rb
	test/profile_test_all.rb
	test/rake/
	test/rdoc/test.ja.large.rdoc
	test/rdoc/test_attribute_manager.rb
	test/rexml/data/ticket_110_utf16.xml
	test/rexml/test_encoding_2.rb
	test/rexml/test_xpath.rb
	test/rexml/test_xpath_attribute_query.rb
	test/rexml/test_xpath_msw.rb
	test/rexml/test_xpath_pred.rb
	test/rexml/test_xpathtext.rb
	test/ruby/endblockwarn_rb
	test/ruby/envutil.rb
	test/ruby/find_executable.rb
	test/ruby/memory_status.rb
	test/rubygems/insure_session.rb
	test/rubygems/test_gem_dependency_resolver.rb
	test/rubygems/test_gem_dependency_resolver_activation_request.rb
	test/rubygems/test_gem_dependency_resolver_api_set.rb
	test/rubygems/test_gem_dependency_resolver_api_specification.rb
	test/rubygems/test_gem_dependency_resolver_best_set.rb
	test/rubygems/test_gem_dependency_resolver_dependency_conflict.rb
	test/rubygems/test_gem_dependency_resolver_dependency_request.rb
	test/rubygems/test_gem_dependency_resolver_index_set.rb
	test/rubygems/test_gem_dependency_resolver_index_specification.rb
	test/rubygems/test_gem_dependency_resolver_installed_specification.rb
	test/rubygems/test_gem_dependency_resolver_installer_set.rb
	test/rubygems/test_gem_dependency_resolver_lock_set.rb
	test/rubygems/test_gem_dependency_resolver_vendor_set.rb
	test/rubygems/test_gem_dependency_resolver_vendor_specification.rb
	test/test_curses.rb
	test/testunit/test_rake_integration.rb
	test/with_different_ofs.rb

There's a good chance we're not running any of these, but we should evaluate them and probably delete them from the JRuby repo.

@headius headius added this to the JRuby 9.1.7.0 milestone Nov 14, 2016

@headius headius closed this in 61dc0de Dec 12, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment