New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

JRuby raises 'syntax error, unexpected kDO_BLOCK' where MRI does not #4663

Closed
eprothro opened this Issue Jun 9, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@eprothro

eprothro commented Jun 9, 2017

Experienced in 9.1.5.0, reproduced in 9.1.9.0 as well.

SyntaxError: /Users/eprothro/.rbenv/versions/jruby-9.1.9.0/lib/ruby/gems/shared/gems/perform-later-1.0.0/lib/perform_later/aliasing.rb:47: syntax error, unexpected kDO_BLOCK
        perform_async(method, *args).tap do |id|

  org/jruby/RubyKernel.java:961:in `require'

Patch showing workaround with different block syntax:

eprothro/perform-later@2b7e9ed#diff-27c9b4687d0af0abaa0b859ff0486858

@enebo

This comment has been minimized.

Show comment
Hide comment
@enebo

enebo Jun 12, 2017

Member

Reduced to:

foo ->() do
  bar.gar do |id|
  end
end

So stabby needs to be an argument for this to fail AND gar needs to be a call and not an fcall.

Member

enebo commented Jun 12, 2017

Reduced to:

foo ->() do
  bar.gar do |id|
  end
end

So stabby needs to be an argument for this to fail AND gar needs to be a call and not an fcall.

@enebo enebo added the parser label Jun 12, 2017

@enebo enebo added this to the JRuby 9.1.11.0 milestone Jun 12, 2017

@enebo enebo closed this in 577c7a5 Jun 12, 2017

enebo added a commit that referenced this issue Jun 12, 2017

Update ripper parser for same fix as in #4663. JRuby raises 'syntax e…
…rror, unexpected kDO_BLOCK' where MRI does not.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment