You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
Found it because the Maven Enforcer Plugin got angry when the Apache HBase project tried to upgrade from 184.108.40.206 to 220.127.116.11
[INFO] Restricted to JDK 1.8 yet org.jruby:jruby-complete:jar:18.104.22.168:compile contains module-info.class targeted to JDK 1.9
[WARNING] Rule 4: org.apache.maven.plugins.enforcer.EnforceBytecodeVersion failed with message:
HBase has unsupported dependencies.
HBase requires that all dependencies be compiled with version 1.8 or earlier
of the JDK to properly build from source. You appear to be using a newer dependency. You can use
either "mvn -version" or "mvn enforcer:display-info" to verify what version is active.
Non-release builds can temporarily build with a newer JDK version by setting the
'compileSource' property (eg. mvn -DcompileSource=1.8 clean package).
Found Banned Dependency: org.jruby:jruby-complete:jar:22.214.171.124
Use 'mvn dependency:tree' to locate the source of the banned dependencies.