Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

upgrade mavengem extension #5361

Merged
merged 2 commits into from Oct 12, 2018

Conversation

Projects
None yet
3 participants
@mkristian
Copy link
Member

mkristian commented Oct 12, 2018

@kares in case I do not get this merged today please feel free to merge - if CI says OK of course ;)

@mkristian mkristian requested a review from kares Oct 12, 2018

@headius headius added this to the JRuby 9.2.1.0 milestone Oct 12, 2018

@headius

This comment has been minimized.

Copy link
Member

headius commented Oct 12, 2018

Weird error killed all the builds:

org.apache.maven.InternalErrorException: Internal error: org.jruby.embed.InvokeFailedException: (SyntaxError) /home/travis/build/jruby/jruby/lib/pom.rb:77: syntax error, unexpected tIDENTIFIER
  repository :id => :mavengems, :url => 'mavengem:https://rubygems.org'

You didn't even change that line 😢

@headius

This comment has been minimized.

Copy link
Member

headius commented Oct 12, 2018

Oh I see...missed that the builds ran before the most recent commit 👍

@kares kares changed the title upgrde mavengem extension upgrade mavengem extension Oct 12, 2018

@headius

This comment has been minimized.

Copy link
Member

headius commented Oct 12, 2018

Looks good!

@headius headius merged commit 5448a3f into master Oct 12, 2018

2 checks passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
continuous-integration/travis-ci/push The Travis CI build passed
Details
@kares

This comment has been minimized.

Copy link
Member

kares commented Oct 12, 2018

will rebase #5340 too see how its going on CI

@kares

This comment has been minimized.

Copy link
Member

kares commented Oct 12, 2018

hmm, still picking up 9.1.8.0 and thus failing to build on CI w Java 11.
https://travis-ci.org/jruby/jruby/jobs/440689940#L509 ... wonder if its due smt being cached on Travis

@headius

This comment has been minimized.

Copy link
Member

headius commented Oct 12, 2018

It's working for me now, suddenly. Are there some soft-version dependencies in the chain perhaps, allowing it to pick up an older version before artifacts propagate?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.