Use the 1.9 flag for compilation if we're in 1.9 mode #99

Closed
wants to merge 2 commits into
from

Projects

None yet

7 participants

@hawknewton

Use jruby with the --1.9 flag if the current runtime is configured for it.

Owner
kares commented Jun 6, 2012

najs, would be great to have a spec or two :)

After I introduce a 1.9 class to sample_jar compilation should succeed if RUBY_VERSION is 1.9.3 but should fail if RUBY_VERSION is 1.8.7. Does that sound like the right approach?

Thanks!

BEHOLD! ... specs. Hope you like 'em WET.

mockaroo commented Sep 6, 2012

There has been a pull request around for this for quite some time. Is there any chance of it getting merged? It would be immensely helpful.

lumpidu commented Sep 13, 2012

I was also stumbling over it. Gives a warbler newbie some unnecessary time for hunting it down.

Contributor

Doh. I issued a pull request #117 on this before seeing someone else had already done it. I would argue that implementing it based off of config.webxml.jruby.compat.version is perhaps a better implementation as it depends on the version the webapp is meant to be run in, rather than depending on the mode used when compiling your webapp.

FWIW, I agree.

Member

This looks fine for me so I'm merging it

/cc @kares @nicksieger let me know if you disagree

Member

sorry, my last comment was for #117, no for this :)

Member

Closing this since #117 is now merged

Contributor
sgonyea commented Dec 28, 2012

Any chance a new gem might be cut?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment