Fix deprecation warnings with ActiveSupport ~> 2.3.5 #64

Closed
wants to merge 1 commit into
from

Conversation

Projects
None yet
6 participants
Contributor

cgriego commented Apr 4, 2011

I've gotten tired of this message in my console. :)

DEPRECATION WARNING: require "activesupport" is deprecated and will be removed in Rails 3. Use require "active_support" instead. (called from /vendor/bundle/ruby/1.8/gems/activesupport-2.3.11/lib/activesupport.rb:2)

I chose this approach instead of a nested begin/rescue block so that people using versions before 2.3.5 didn't have to suffer the overhead of two exception backtraces being generated. I tested with the first and last patch versions of each minor version of ActiveSupport between 2.0.0 and 3.0.5

marksim commented May 10, 2011

+1 On this pull request.

marksim commented Jun 20, 2011

Any reason this hasn't been pulled in?

+1. I submitted this as a pull request back in January, but it sat for months and wasn't pulled in, so don't expect anything to be done anytime soon.

Hoping to get more attention to this, as I've just started to use Metric Fu on a Rail3.1 project.

+1 on this one.

bf4 referenced this pull request in metricfu/metric_fu Jan 29, 2013

Closed

Fix deprecation warnings with ActiveSupport ~> 2.3.5 #21

Collaborator

bf4 commented Dec 6, 2013

Gem no longer maintained, See https://github.com/metricfu/metric_fu

bf4 closed this Dec 6, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment