Permalink
Browse files

No issue: change message for W104

  • Loading branch information...
valueof committed Jan 26, 2014
1 parent 3cb02e3 commit 61cc5e581a66f51055fdb8bae3a8f42397fdd7fd
Showing with 201 additions and 201 deletions.
  1. +1 −1 src/messages.js
  2. +3 −3 tests/unit/core.js
  3. +1 −1 tests/unit/options.js
  4. +196 −196 tests/unit/parser.js
View
@@ -176,7 +176,7 @@ var warnings = {
W101: "Line is too long.",
W102: "Trailing whitespace.",
W103: "The '{a}' property is deprecated.",
- W104: "'{a}' is only available in JavaScript 1.7.",
+ W104: "'{a}' is available in ES6 (use esnext option) or Mozilla JS extensions (use moz).",
W105: "Unexpected {a} in '{b}'.",
W106: "Identifier '{a}' is not in camel case.",
W107: "Script URL.",
View
@@ -691,11 +691,11 @@ exports.testES6Modules = function (test) {
.addError(34, "'export' is only available in ES6 (use esnext option).")
.addError(38, "'export' is only available in ES6 (use esnext option).")
.addError(40, "'export' is only available in ES6 (use esnext option).")
- .addError(40, "'class' is only available in JavaScript 1.7.")
+ .addError(40, "'class' is available in ES6 (use esnext option) or Mozilla JS extensions (use moz).")
.addError(41, "'export' is only available in ES6 (use esnext option).")
- .addError(41, "'class' is only available in JavaScript 1.7.")
+ .addError(41, "'class' is available in ES6 (use esnext option) or Mozilla JS extensions (use moz).")
.addError(42, "'export' is only available in ES6 (use esnext option).")
- .addError(42, "'class' is only available in JavaScript 1.7.")
+ .addError(42, "'class' is available in ES6 (use esnext option) or Mozilla JS extensions (use moz).")
.test(src, {});
var src2 = [
View
@@ -230,7 +230,7 @@ exports.testProtoAndIterator = function (test) {
.addError(7, "The '__proto__' property is deprecated.")
.addError(8, "The '__proto__' property is deprecated.")
.addError(10, "The '__proto__' property is deprecated.")
- .addError(27, "'__iterator__' is only available in JavaScript 1.7.")
+ .addError(27, "'__iterator__' is available in ES6 (use esnext option) or Mozilla JS extensions (use moz).")
.addError(33, "The '__proto__' property is deprecated.")
.addError(37, "The '__proto__' property is deprecated.")
.test(source, {es3: true});
Oops, something went wrong.

0 comments on commit 61cc5e5

Please sign in to comment.