Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Issue with latest jshint npm module #1055

Closed
jleppert opened this Issue · 5 comments

3 participants

@jleppert

When installing jshint globally for use within node -- e.g. require('jshint') -- there are some unmet dependancies/broken package.json:

$ sudo npm install jshint
npm http GET https://registry.npmjs.org/jshint
npm http 200 https://registry.npmjs.org/jshint
npm http GET https://registry.npmjs.org/underscore
npm http GET https://registry.npmjs.org/shelljs
npm http GET http://github.com/ariya/esprima/tarball/master
npm http GET https://registry.npmjs.org/peakle
npm http GET https://registry.npmjs.org/cli
npm http 304 https://registry.npmjs.org/cli
npm http 304 https://registry.npmjs.org/peakle
npm http 304 https://registry.npmjs.org/underscore
npm http 304 https://registry.npmjs.org/shelljs
npm http 200 http://github.com/ariya/esprima/tarball/master
npm WARN prefer global jshint@1.1.0 should be installed with -g
npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/node-gyp/node_modules/glob requires graceful-fs@'~1.1.2' but will load
npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/graceful-fs,
npm WARN unmet dependency which is version 1.2.0
jshint@1.1.0 node_modules/jshint
├── peakle@0.0.1
├── cli@0.4.4-2
├── underscore@1.4.4
├── shelljs@0.1.3
└── esprima@1.1.0-dev

$ node

var blah = require('jshint');
Error: Cannot find module 'console-browserify'
at Function.Module._resolveFilename (module.js:338:15)
at Function.Module._load (module.js:280:25)
at Module.require (module.js:364:17)
at require (module.js:380:17)
at Object. (/usr/local/lib/node_modules/npm/node_modules/jshint/src/stable/jshint.js:47:15)
at Module._compile (module.js:456:26)
at Object.Module._extensions..js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Module.require (module.js:364:17)

$ sudo npm install console-browserify
npm http GET https://registry.npmjs.org/console-browserify
npm http 200 https://registry.npmjs.org/console-browserify
npm http GET https://registry.npmjs.org/console-browserify/-/console-browserify-0.1.6.tgz
npm http 200 https://registry.npmjs.org/console-browserify/-/console-browserify-0.1.6.tgz
npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/node-gyp/node_modules/glob requires graceful-fs@'~1.1.2' but will load
npm WARN unmet dependency /usr/local/lib/node_modules/npm/node_modules/graceful-fs,
npm WARN unmet dependency which is version 1.2.0
console-browserify@0.1.6 node_modules/console-browserify

$ node

var blah = require('jshint');
undefined

@jleppert

ello? Anybody in here?

@jleppert

Yes, and that works but only after following the above steps. The issue is that console-browserify dependancy isn't specified correctly in package.json.

@jleppert

I see you've fixed that as of 7 days ago....can anyone publish the new module to npm?

@nschonni

I think that's fixed in the 2.0 release

@valueof valueof closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.