Skip to content
Customize postcss-import resolve with enhanced-resolve
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.editorconfig
.eslintrc
.gitignore
.npmignore
CHANGELOG.md
LICENSE
index.d.ts
index.js
package.json
readme.md
yarn.lock

readme.md

postcss-import-resolver

JavaScript Style Guide

Installation

$ npm install --save postcss-import-resolver

# or

$ yarn add postcss-import-resolver

Usage (Webpack)

const resolver = require('postcss-import-resolver')
const postcssLoader = {
  loader: 'postcss-loader',
  options: {
    plugins: {
      'postcss-import': {
        resolve: resolver({
          alias: {
            '~': 'src/'
          },
          modules: ['node_modules']
        })
      }
    }
  }
}
You can’t perform that action at this time.