Permalink
Browse files

Version bump to 0.1.0

  • Loading branch information...
1 parent ed123be commit 66783b6e5750409caa736c5b3a6e768cae5cf92b @jsmestad committed Jun 25, 2009
Showing with 66 additions and 19 deletions.
  1. +25 −18 Rakefile
  2. +1 −1 VERSION
  3. +40 −0 frankie.gemspec
View
@@ -1,28 +1,35 @@
require 'rubygems'
-require 'rake/testtask'
-require 'rake/rdoctask'
-require 'echoe'
+require 'rake'
+require 'echoe'
+require 'spec/rake/spectask'
task :default => :test
+
+GEM = "frankie"
+AUTHORS = ["Ron Evans", "Justin Smestad"]
+EMAIL = "justin.smestad@gmail.com"
+HOMEPAGE = "http://facethesinatra.com"
+SUMMARY = "Easy creation of Facebook applications in Ruby using plugin for Sinatra web framework that integrates with Facebooker gem."
-Rake::RDocTask.new do |rd|
- rd.main = "README.rdoc"
- rd.rdoc_files += ["README.rdoc"]
- rd.rdoc_files += Dir.glob("lib/**/*.rb")
- rd.rdoc_dir = 'doc'
-end
+begin
+ require 'jeweler'
+ Jeweler::Tasks.new do |gem|
+ gem.name = GEM
+ gem.summary = SUMMARY
+ gem.email = EMAIL
+ gem.homepage = HOMEPAGE
+ gem.authors = AUTHORS
+ # gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
+ gem.add_dependency "sinatra", ">= 0.9.2"
+ gem.add_dependency 'facebooker', ">= 0.9.5"
+ end
+rescue LoadError
+ puts "Jeweler (or a dependency) not available. Install it with: sudo gem install jeweler"
+end
+
Rake::TestTask.new do |t|
ENV['SINATRA_ENV'] = 'test'
t.pattern = File.dirname(__FILE__) + "/test/*_test.rb"
end
-
-Echoe.new("frankie") do |p|
- p.author = "Ron Evans"
- p.summary = "Easy creation of Facebook applications in Ruby using plugin for Sinatra web framework that integrates with Facebooker gem."
- p.url = "http://facethesinatra.com/"
- p.dependencies = ["sinatra >=0.2.2", "facebooker >=0.9.5"]
- p.install_message = "*** Frankie was installed ***"
- p.include_rakefile = true
-end
View
@@ -1 +1 @@
-0.0.0
+0.1.0
View
@@ -0,0 +1,40 @@
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = %q{frankie}
+ s.version = "0.3.0"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 1.2") if s.respond_to? :required_rubygems_version=
+ s.authors = ["Ron Evans"]
+ s.date = %q{2009-06-25}
+ s.default_executable = %q{tunnel}
+ s.description = %q{Easy creation of Facebook applications in Ruby using plugin for Sinatra web framework that integrates with Facebooker gem.}
+ s.email = %q{}
+ s.executables = ["tunnel"]
+ s.extra_rdoc_files = ["bin/tunnel", "CHANGELOG", "lib/frankie.rb", "LICENSE", "README.rdoc"]
+ s.files = ["bin/tunnel", "CHANGELOG", "lib/frankie.rb", "LICENSE", "Manifest", "Rakefile", "README.rdoc", "test/frankie_test.rb", "test/helper.rb", "frankie.gemspec"]
+ s.homepage = %q{http://facethesinatra.com/}
+ s.post_install_message = %q{*** Frankie was installed ***}
+ s.rdoc_options = ["--line-numbers", "--inline-source", "--title", "Frankie", "--main", "README.rdoc"]
+ s.require_paths = ["lib"]
+ s.rubyforge_project = %q{frankie}
+ s.rubygems_version = %q{1.3.4}
+ s.summary = %q{Easy creation of Facebook applications in Ruby using plugin for Sinatra web framework that integrates with Facebooker gem.}
+ s.test_files = ["test/frankie_test.rb"]
+
+ if s.respond_to? :specification_version then
+ current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
+ s.specification_version = 3
+
+ if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<sinatra>, [">= 0.2.2"])
+ s.add_runtime_dependency(%q<facebooker>, [">= 0.9.5"])
+ else
+ s.add_dependency(%q<sinatra>, [">= 0.2.2"])
+ s.add_dependency(%q<facebooker>, [">= 0.9.5"])
+ end
+ else
+ s.add_dependency(%q<sinatra>, [">= 0.2.2"])
+ s.add_dependency(%q<facebooker>, [">= 0.9.5"])
+ end
+end

0 comments on commit 66783b6

Please sign in to comment.