Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Remove the case of PKG_PHP_VERSION is 4.

No functional change.
  • Loading branch information...
commit 2160a272f460e818601d6a340cf83b5a7d69a0ca 1 parent fdf9251
taca authored
7 mail/roundcube/Makefile
View
@@ -1,4 +1,4 @@
-# $NetBSD: Makefile,v 1.23 2009/12/31 16:56:18 abs Exp $
+# $NetBSD: Makefile,v 1.24 2010/03/15 16:48:53 taca Exp $
#
DISTNAME= roundcubemail-${RCVERSION}-dep
@@ -29,12 +29,7 @@ DEPENDS+= ${PHP_PKG_PREFIX}-pear-Net_SMTP>=1.2.10:../../net/pear-Net_SMTP
DEPENDS+= ${PHP_PKG_PREFIX}-pear-Mail_Mime>=1.3:../../mail/pear-Mail_Mime
DEPENDS+= ${PHP_PKG_PREFIX}-pear-MDB2>=2.4.1:../../databases/pear-MDB2
DEPENDS+= ${PHP_PKG_PREFIX}-pear-Auth_SASL-[0-9]*:../../mail/pear-Auth_SASL
-
-.if ${PKG_PHP_VERSION} == "4"
-DEPENDS+= ${PHP_PKG_PREFIX}-domxml>=4.3.3:../../textproc/php4-domxml
-.elif ${PKG_PHP_VERSION} == "5"
DEPENDS+= ${PHP_PKG_PREFIX}-dom-[0-9]*:../../textproc/php5-dom
-.endif
PKG_SYSCONFSUBDIR?= roundcube
14 net/php-xmlrpc/Makefile
View
@@ -1,4 +1,4 @@
-# $NetBSD: Makefile,v 1.10 2008/06/12 02:14:41 joerg Exp $
+# $NetBSD: Makefile,v 1.11 2010/03/15 16:48:53 taca Exp $
MODNAME= xmlrpc
CATEGORIES+= net
@@ -14,14 +14,7 @@ CONFIGURE_ARGS+= --enable-${MODNAME}=shared,${BUILDLINK_DIR}
.include "../../lang/php/phpversion.mk"
-.if ${PKG_PHP_VERSION} == 5
-# the extension has been changed in PHP 5.1 to require libxml2; while
-# there is some "compatibility" expat configure setting, it doesn't build
-# with that
CONFIGURE_ARGS+= --with-libxml-dir=${BUILDLINK_PREFIX.libxml2}
-.else
-CONFIGURE_ARGS+= --with-expat-dir=${BUILDLINK_PREFIX.expat}
-.endif
.include "../../converters/libiconv/buildlink3.mk"
@@ -39,11 +32,6 @@ CONFIGURE_ARGS+= --with-iconv-dir=${BUILDLINK_PREFIX.iconv}
CONFIGURE_ARGS+= --with-iconv-dir
.endif
-.if ${PKG_PHP_VERSION} == 5
.include "../../textproc/libxml2/buildlink3.mk"
-.else
-.include "../../textproc/expat/buildlink3.mk"
-.endif
-
.include "../../lang/php/ext.mk"
.include "../../mk/bsd.pkg.mk"
12 textproc/php-wddx/Makefile
View
@@ -1,4 +1,4 @@
-# $NetBSD: Makefile,v 1.14 2008/06/12 02:14:51 joerg Exp $
+# $NetBSD: Makefile,v 1.15 2010/03/15 16:48:53 taca Exp $
MODNAME= wddx
CATEGORIES+= textproc
@@ -9,6 +9,7 @@ PKG_DESTDIR_SUPPORT= user-destdir
CONFLICTS= php-wddx-[0-9]*
CONFIGURE_ARGS+= --enable-${MODNAME}=shared,${BUILDLINK_DIR}
+CONFIGURE_ARGS+= --with-libxml-dir=${BUILDLINK_DIR}
USE_PHP_EXT_PATCHES= # defined
@@ -16,16 +17,7 @@ USE_PHP_EXT_PATCHES= # defined
CFLAGS+= -I${BUILDLINK_DIR}/include/libxml2 \
-I${BUILDLINK_DIR}/include/php/ext/date/lib
-
.include "../../lang/php/phpversion.mk"
-
-# link against libxml2 on PHP5
-.if ${PKG_PHP_VERSION} == 5
-CONFIGURE_ARGS+= --with-libxml-dir=${BUILDLINK_DIR}
.include "../../textproc/libxml2/buildlink3.mk"
-.else
-.include "../../textproc/expat/buildlink3.mk"
-.endif
-
.include "../../lang/php/ext.mk"
.include "../../mk/bsd.pkg.mk"
7 www/drupal/Makefile
View
@@ -1,4 +1,4 @@
-# $NetBSD: Makefile,v 1.44 2010/03/04 01:29:39 taca Exp $
+# $NetBSD: Makefile,v 1.45 2010/03/15 16:48:53 taca Exp $
DISTNAME= drupal-5.22
CATEGORIES= www
@@ -13,6 +13,7 @@ CONFLICTS+= drupal-6.*{,nb*}
DEPENDS+= ${APACHE_PKG_PREFIX}-${PHP_PKG_PREFIX}>=4.3.3:../../www/ap-php
DEPENDS+= ${PHP_PKG_PREFIX}-gd>=4.3.3:../../graphics/php-gd
+DEPENDS+= php>=5.2.4:../../lang/php5
NO_BUILD= YES
DRUPAL= ${PREFIX}/share/drupal
@@ -48,10 +49,6 @@ PKG_DESTDIR_SUPPORT= user-destdir
.include "../../mk/apachever.mk"
.include "../../lang/php/phpversion.mk"
-.if ${PKG_PHP_VERSION} == "5"
-DEPENDS+= php>=5.2.4:../../lang/php5
-.endif
-
.include "options.mk"
post-extract:
6 www/drupal/options.mk
View
@@ -1,4 +1,4 @@
-# $NetBSD: options.mk,v 1.3 2006/06/02 18:28:00 joerg Exp $
+# $NetBSD: options.mk,v 1.4 2010/03/15 16:48:53 taca Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.drupal
@@ -29,9 +29,5 @@ DEPENDS+= ${PHP_PKG_PREFIX}-mysql>=4.3.3:../../databases/php-mysql
### syndication.
###
.if !empty(PKG_OPTIONS:Mdrupal-xmlservices)
-. if ${PKG_PHP_VERSION} == "4"
-DEPENDS+= ${PHP_PKG_PREFIX}-domxml>=4.3.3:../../textproc/php4-domxml
-. elif ${PKG_PHP_VERSION} == "5"
DEPENDS+= ${PHP_PKG_PREFIX}-dom-[0-9]*:../../textproc/php5-dom
-. endif
.endif
7 www/drupal6/Makefile
View
@@ -1,4 +1,4 @@
-# $NetBSD: Makefile,v 1.19 2010/03/04 01:29:58 taca Exp $
+# $NetBSD: Makefile,v 1.20 2010/03/15 16:48:53 taca Exp $
DISTNAME= drupal-6.16
CATEGORIES= www
@@ -11,6 +11,7 @@ LICENSE= gnu-gpl-v2
CONFLICTS+= drupal-5.*{,nb*}
+DEPENDS+= php>=5.2.0:../../lang/php5
DEPENDS+= ${PHP_PKG_PREFIX}-gd>=4.3.5:../../graphics/php-gd
NO_BUILD= YES
@@ -57,10 +58,6 @@ PKG_DESTDIR_SUPPORT= user-destdir
.include "../../lang/php/phpversion.mk"
-.if ${PKG_PHP_VERSION} == "5"
-DEPENDS+= php>=5.2.0:../../lang/php5
-.endif
-
.include "options.mk"
OWN_DIRS= share/drupal/sites/default
6 www/drupal6/options.mk
View
@@ -1,4 +1,4 @@
-# $NetBSD: options.mk,v 1.3 2009/02/16 21:02:26 adrianp Exp $
+# $NetBSD: options.mk,v 1.4 2010/03/15 16:48:53 taca Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.drupal
@@ -29,11 +29,7 @@ DEPENDS+= ${PHP_PKG_PREFIX}-mysql>=4.3.3:../../databases/php-mysql
### syndication.
###
.if !empty(PKG_OPTIONS:Mdrupal-xmlservices)
-. if ${PKG_PHP_VERSION} == "4"
-DEPENDS+= ${PHP_PKG_PREFIX}-domxml>=4.3.3:../../textproc/php4-domxml
-. elif ${PKG_PHP_VERSION} == "5"
DEPENDS+= ${PHP_PKG_PREFIX}-dom-[0-9]*:../../textproc/php5-dom
-. endif
.endif
###
6 www/horde/Makefile
View
@@ -1,4 +1,4 @@
-# $NetBSD: Makefile,v 1.66 2010/02/16 16:08:59 joerg Exp $
+# $NetBSD: Makefile,v 1.67 2010/03/15 16:48:53 taca Exp $
DISTNAME= horde-3.3.6
PKGREVISION= 1
@@ -24,11 +24,7 @@ DEPENDS+= ${PHP_PKG_PREFIX}-pear-Log-[0-9]*:../../sysutils/pear-Log
DEPENDS+= ${PHP_PKG_PREFIX}-pear-Mail_Mime-[0-9]*:../../mail/pear-Mail_Mime
DEPENDS+= ${PHP_PKG_PREFIX}-pear-DB-[0-9]*:../../databases/pear-DB
DEPENDS+= ${APACHE_PKG_PREFIX}-${PHP_PKG_PREFIX}>=4.3.3:../../www/ap-php
-.if ${PKG_PHP_VERSION} == "4"
-DEPENDS+= ${PHP_PKG_PREFIX}-domxml>=4.3.3:../../textproc/php4-domxml
-.elif ${PKG_PHP_VERSION} == "5"
DEPENDS+= ${PHP_PKG_PREFIX}-dom-[0-9]*:../../textproc/php5-dom
-.endif
DEPENDS+= ${PHP_PKG_PREFIX}-zlib>=4.3.3:../../archivers/php-zlib
DEPENDS+= ${PHP_PKG_PREFIX}-pear-Console_Table-[0-9]*:../../textproc/pear-Console_Table
DEPENDS+= ${PHP_PKG_PREFIX}-pear-File_Find-[0-9]*:../../textproc/pear-File_Find
7 www/wordpress/options.mk
View
@@ -1,4 +1,4 @@
-# $NetBSD: options.mk,v 1.1.1.1 2009/04/06 11:31:02 adrianp Exp $
+# $NetBSD: options.mk,v 1.2 2010/03/15 16:48:53 taca Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.wordpress
@@ -10,12 +10,7 @@ PKG_SUGGESTED_OPTIONS= ap-php
.include "../../mk/bsd.options.mk"
.if !empty(PKG_OPTIONS:Mphp-cgi)
-. if ${PKG_PHP_VERSION} == "4"
-DEPENDS+= php>=4.4.7:../../www/php4
-. endif
-. if ${PKG_PHP_VERSION} == "5"
DEPENDS+= php>=5.2.4:../../lang/php5
-. endif
.endif
.if !empty(PKG_OPTIONS:Map-php)
Please sign in to comment.
Something went wrong with that request. Please try again.