Skip to content
Browse files

Disable assembler support under NetBSD 5.1 and older as it required

binutils 2.17 or newer which is only available under NetBSD-current.
  • Loading branch information...
1 parent 573aa64 commit 6554faee4dad090d813e4a5f2397dffadb4f38cf tron committed Jan 17, 2011
Showing with 7 additions and 1 deletion.
  1. +7 −1 multimedia/x264-devel/Makefile
View
8 multimedia/x264-devel/Makefile
@@ -1,4 +1,4 @@
-# $NetBSD: Makefile,v 1.27 2011/01/17 21:51:09 tron Exp $
+# $NetBSD: Makefile,v 1.28 2011/01/17 22:06:37 tron Exp $
SNAPSHOT_DATE= 20110101
@@ -29,7 +29,13 @@ CONFIGURE_ARGS+= --disable-asm
BUILD_DEPENDS+= yasm>=0.4.0:../../devel/yasm
. endif
.elif ${MACHINE_ARCH} == "x86_64"
+. if ${OPSYS} == "SunOS" || (${OPSYS} == "NetBSD" && \
+ (!empty(OS_VERSION:M[1-5].*) && empty(OS_VERSION:M5.99.*))) || \
+ ${OPSYS} == "Darwin"
+CONFIGURE_ARGS+= --disable-asm
+. else
BUILD_DEPENDS+= yasm>=0.4.0:../../devel/yasm
+. endif
.elif ${MACHINE_ARCH} == "arm" && ${OPSYS} == "NetBSD"
# pre-ARMv6 is default on NetBSD/arm
CONFIGURE_ARGS+= --disable-asm

0 comments on commit 6554fae

Please sign in to comment.
Something went wrong with that request. Please try again.