Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Commits on Sep 29, 2012
  1. Recognize tcl 8.5. Should fix tcl-pdflib.

    dholland authored
Commits on Sep 27, 2012
  1. Fix up compiler flags on Solaris, you cannot have both _XOPEN_SOURCE=…

    jperkin authored
    …600 and
    
    _XOPEN_SOURCE_EXTENDED=1 in C99 code.
    
    Fixes package on Solaris.
Commits on Sep 21, 2012
  1. Fix PR pkg/46766

    ryoon authored
    When run 'make package' as root, avoid /usr/bin/acroread symlink creation.
Commits on Sep 20, 2012
  1. add and enable p5-biblatex-biber

    jnemeth authored
Commits on Sep 18, 2012
  1. fix libtool problem in unpriliged build

    drochner authored
    use the right libusb
  2. Update to 1.5.4 (ok by wiz@):

    bouyer authored
            - Documentation updates (STR #4112, STR #4130, STR #4134)
            - Fixes for libusb-based USB backend (STR #4128)
            - The lpq command did not show the owner or title of jobs unless passed
              a username on the command-line (STR #4135)
            - Localized empty strings contained the message catalog metadata
              (STR #4119)
            - Fixed a crash in the libusb-based USB backend (STR #4099)
            - The cups-lpd mini-daemon no longer handled jobs with multiple copies
              (STR #4118)
            - Multiple libusb backend fixes (STR #4098, STR #4100)
            - The IPP backend no longer tries to get the job status for printers
              that do not implement the required operation (STR #4083)
            - Sending a document in an unsupported format to an IPP printer now
              automatically cancels the job (STR #4093)
            - Fix some error reporting issues when printing from /dev/null and
              other unusual situations (STR #4015)
            - The scheduler now sets the CUPS_MAX_MESSAGE environment variable for
              filters (STR #4074)
            - Fixed a build issue when using older versions of autoconf (STR #4084)
            - The IPP backend now treats the client-error-not-possible status code
              as a job history issue, allowing IPP printing to Windows to work
              (STR #4047)
            - The IPP backend incorrectly included the document-format and
              compression attributes in Create-Job requests (STR #4086)
            - The libusb-based USB backend did not work on non-Linux platforms
              (STR #4088)
    
            - httpReconnect() did not reset the read/write buffers (STR #4065)
            - Compiling without threading support failed (STR #4060)
            - Fixed compile problem with old versions of OpenSSL (STR #4036)
            - The network backends did not check SNMP supply levels regularly
              (STR #4040)
            - The online help always included the "help on help" text (STR #4042)
            - Fixed a SSL handshake issue on OS X (STR #4045)
            - The scheduler could crash if a PPD file contained an invalid paper
              size (STR #4049)
            - The CUPS polling daemon did not reinitialize its connection to the
              remote server on errors in all cases (STR #4031)
            - PostScript auto-configuration was slow and unreliable with some
              printers (STR #4028)
            - Missing localizations caused empty output (STR #4033)
            - The cups-driverd program could temporarily "forget" a PPD file if it
              was updated in place.
            - The dnssd backend now prefers IPPS over IPP.
            - The USB backend now uses and requires LIBUSB 1.0 or later (STR #3477)
            - The LIBUSB-based USB backend now supports the back-channel (STR #2890)
            - Changed how timeouts are implemented in the LPD backend (STR #4013)
            - Added more supported color names for SNMP supplies (STR #3981)
            - The default InputSlot setting was never used (STR #3957)
            - POSIX ACLs are now set properly on certificate files (STR #3970)
            - Supplies with commas in their names were not reported correctly
              (STR #4020)
            - The cupsGetPPD3() function created a temporary file when one was not
              needed (STR #4018)
            - The scheduler now ensures that job notifications contain a value for
              the notify-printer-uri attribute (STR #4014)
            - The lp and lpr commands did not cancel jobs queued from stdin on an
              error (STR #4015)
            - Fixed the IPP backend's handling of HTTP/1.0 compatibility (STR #3988)
            - The IPP backend did not always setup username/password authentication
              for printers (STR #3985)
            - The IPP backend no longer re-queues print jobs that are too large for
              the printer/server (STR #3977)
            - The RPM spec file did not work (STR #4021, STR #4057)
            - Encryption did not work when the server name ended with "."
              (STR #4011)
            - The multi-purpose tray is now mapped to the IPP "by-pass-tray"
              (STR #4009)
            - The correct media size was not always passed to IPP printers
              (STR #4001)
            - Finishing options were not passed to IPP printers (STR #3995)
            - Fixed iCloud-based Back to My Mac printing (STR #3996)
Commits on Sep 16, 2012
  1. Update ruby-pdf-reader to 1.2.0.

    taca authored
    v1.2.0 (28th AUgust 2012)
    - Feature: correctly extract text using surrogate pairs and ligatures
      (thanks Nathaniel Madura)
    - Speed optimisation: cache tokenised Form XObjects to avoid re-parsing them
    - Feature: support opening documents with some junk bytes prepended to file
      (thanks Paul Gallagher)
      - Acrobat does this, so it seemed reasonable to add support
Commits on Sep 15, 2012
  1. recursive bump from libffi shlib major bump

    obache authored
    (additionaly, reset PKGREVISION of qt4-* sub packages from base qt4 update)
  2. There are reports about missing dependencies. Removed for the time being

    is authored
    to avoid blocked bulk builds.
Commits on Sep 14, 2012
  1. Add p5-biblatex-biber

    is authored
  2. BibLaTeX-Biber package (0.9.9, the last one working with biblatex 1.7).

    is authored
    This is in modular form, with the necessary dependencies noted.
  3. revbump for poppler update

    drochner authored
  4. bump dependencies for shlib major change

    drochner authored
  5. update to 0.20.4

    drochner authored
    changes:
    -Improvements regarding embedded file handling
    -bugfixes
    -cleanup
    
    pkgsrc note: shlib major changes, revbumps needed. also switch to
     lcms2 for the "cms" option
Commits on Sep 13, 2012
  1. add and enable tex-shadethm

    jnemeth authored
Commits on Sep 12, 2012
  1. Shaded theorem environment.

    is authored
  2. add patch from RedHat to fix integer overflow which can lead to

    drochner authored
    crashes or possible code injection (CVE-2012-4405)
    bump PKGREV
Commits on Sep 7, 2012
  1. Revbump after updating graphics/cairo

    adam authored
Commits on Aug 31, 2012
  1. Update to 0.06

    wen authored
    Upstream changes:
    2012-08-29  Andrew Ford  <a.ford@ford-mason.co.uk>
    
            * version 0.06
    
            * added script "latex-encode" as a simple filter that uses LaTeX::Encode
    
            * added a couple more encodings
    
            * reverted to 'base' from 'parent' for setting up inheritance
    
            * updated author tests
Commits on Aug 30, 2012
  1. == Ruby-GNOME2 1.1.5: 2012-08-29

    obache authored
    This is a network support improvement release!
    
    === Changes
    
    ==== Ruby/GLib2
    
      * Improvements
        * windows: Bundled glib-networking.
    
    ==== Ruby/GIO2
    
      * Improvements
        * Added Gio::TlsCertificate.
        * Added Gio::TlsCertificateFlags.
    
    ==== Ruby/GTK2
    
      * Improvements
        * Added Gtk.show_uri.
    
      * Fixes
        * Gtk::TreeStore#reorder:
          Fixed wrong the number of reorder values check.
          [SF.net#3561748] [Reported by Nounou]
Commits on Aug 29, 2012
  1. Update to 0.0.5

    wen authored
    Upstream changes:
    2012-08-28  Andrew Ford  <a.ford@ford-mason.co.uk>
    
            * version 0.05
    
            * added more symbols
    
            * build-character-table now builds a %provided_by map that gives the LaTeX package
              that provides the LaTeX command used in the encoding
    
            * removed unimplemented "use_textcomp" option
    
            * added "packages" option to latex_encode() to pass a reference to a hash that is
              updated with the names of optional LaTeX packages (styles) that implement the
              commands included in the encoded string
    
    2012-08-27  Andrew Ford  <a.ford@ford-mason.co.uk>
    
            * version 0.04
    
            * added requirement for Perl 5.8.1 or later due to deficiencies in
              Unicode handling of earlier Perl versions.
    
            * updated encoding table to add Turkish characters (RT #55526) and to not include
              spaces after accented characters (RT #49357)
    
            * switch from 'base' to 'parent' for setting up inheritance
    
            * added add_latex_encodings() and remove_latex_encodings() functions to update the
              encoding table.
    
            * allow 'add' and 'remove' specifiers to be provided on the 'use' statement
Commits on Aug 25, 2012
  1. Do not install man page into /usr/share.

    wiz authored
    Bump PKGREVISION.
Commits on Aug 22, 2012
  1. Disable -ffunction-sections -fdata-sections and accompanying

    dholland authored
    --gc-sections on netbsd because --gc-sections doesn't work with the
    netbsd-4 and netbsd-5 linker. See PR 46698 and PR 40401.
    
    Bump PKGREVISION because this changes the compiled package on netbsd-6.
Commits on Aug 21, 2012
  1. update to 1.1, from Leonardo Taccari per PR pkg/46823

    drochner authored
    changes:
    The command line tools have been combined into one tool that does all:
     mubusy. Where previously you would have called "mupdfclean blah blah
     blah", now call "mubusy clean blah blah blah" instead.
    Support for UserUnits
    bugfixes and optimisations
Commits on Aug 14, 2012
  1. web2c requires ptexenc>=1.3.0.

    minskim authored
    This fixes PR 46787.
  2. Instead of pass down LUA_ROOT as CFLAGS, replace its definition in th…

    obache authored
    …e source,
    
    avoid to specify nasty C string macro in the command line.
Commits on Aug 13, 2012
  1. Update dvipsk to 5.992.

    minskim authored
    Changes:
    - `c' config file include directive.
  2. print/poppler016: Fix poppler-qt.pc (Fixes KOffice, kdegraphics3)

    marino authored
    Remove a dependency to poppler-0.16 in the poppler-qt.pc file so
    that pkg-config --cflags "poppler-qt >= 0.3.1" returns valid information.
    
    Default poppler version is now 0.20.x.  Since this package explicitly uses
    0.16.x, @PC_REQUIRES_PRIVATE@ introduces a dependency to poppler-0.16.x in
    the .pc file; pkg-config will then print messages such as "Package
    'poppler-qt' requires 'poppler = 0.16.7' but version of poppler is 0.20.2"
    instead of the required information.  Removing the Requires.private line
    entirely fixes the issue.
    
    After applying this patch and rebuilding poppler-qt, graphics/kdegraphics3
    and misc/koffice now build on DragonFly.  Previously they failed with
    poppler-related errors.
    
    Patch provided by F.Tigeot.
  3. PKGREV bump for poppler shlib major change

    drochner authored
Something went wrong with that request. Please try again.