Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Commits on Oct 3, 2012
  1. Bump all packages that use perl, or depend on a p5-* package, or

    wiz authored
    are called p5-*.
    
    I hope that's all of them.
Commits on Aug 14, 2011
  1. Revision bump after updating perl5 to 5.14.1.

    obache authored
Commits on Aug 21, 2010
  1. Bump the PKGREVISION for all packages which depend directly on perl,

    seb authored
    to trigger/signal a rebuild for the transition 5.10.1 -> 5.12.1.
    
    The list of packages is computed by finding all packages which end
    up having either of PERL5_USE_PACKLIST, BUILDLINK_API_DEPENDS.perl,
    or PERL5_PACKLIST defined in their make setup (tested via
    "make show-vars VARNAMES=..."), minus the packages updated after
    the perl package update.
    
    sno@ was right after all, obache@ kindly asked and he@ led the
    way. Thanks!
Commits on Mar 10, 2010
  1. Updating devel/p5-MRO-Compat from 0.11 to 0.11nb1

    sno authored
    pkgsrc changes:
    - Remove dependencies to Class::C3 modules, they're required for
      perl <= 5.9.5 only
Commits on Jun 13, 2009
  1. Ran pkglint --autofix on the devel/ category. Most of the changes are

    rillig authored
    simple white-space issues like indentation and trailing spaces. The
    others are cross-references for Makefile.common.
Commits on Jun 12, 2009
  1. pkgsrc changes:

    sno authored
      - Updating package for p5 module MRO::Compat from 0.10 to 0.11
      - Correcting license to ${PERL5_LICENSE}
      - Adjusting dependencies according to META.yaml
    
    Upstream changes:
    0.11 - Wed May 27, 2009
        - Fix misspelled docs for get_isarev. Closes RT#46401.
        - Bump optional prereq on Class::C3 to 0.20.
Commits on Apr 12, 2009
  1. PkgSrc changes:

    sno authored
      - Updating package for p5 module MRO::Compat to 0.10
      - set license to artistic-2.0
    
    Upstream changes:
    0.10 - Wed Mar 25, 2009
        - Remove the fake Build.PL. Module::Install doesn't support that anymore.
          (Florian Ragwitz)
        - Remove auto_install from Makefile.PL. Its use is strongly discouraged.
          (Closes RT#44542) (Simon Betrang)
Commits on Oct 19, 2008
  1. Bump the PKGREVISION for all packages which depend directly on perl,

    he authored
    to trigger/signal a rebuild for the transition 5.8.8 -> 5.10.0.
    
    The list of packages is computed by finding all packages which end
    up having either of PERL5_USE_PACKLIST, BUILDLINK_API_DEPENDS.perl,
    or PERL5_PACKLIST defined in their make setup (tested via
    "make show-vars VARNAMES=...").
Commits on Jun 24, 2008
  1. import devel/p5-MRO-Compat-0.09 (needed by devel/p5-Class-Accessor-Gr…

    abs authored
    …ouped)
    
    The "mro" namespace provides several utilities for dealing with
    method resolution order and method caching in general in Perl 5.9.5
    and higher.
    
    This module provides those interfaces for earlier versions of Perl
    (back to 5.6.0 anyways).
    
    It is a harmless no-op to use this module on 5.9.5+. That is to
    say, code which properly uses MRO::Compat will work unmodified on
    both older Perls and 5.9.5+.
    
    If you're writing a piece of software that would like to use the
    parts of 5.9.5+'s mro:: interfaces that are supported here, and
    you want compatibility with older Perls, this is the module for
    you.
    
    Some parts of this code will work better and/or faster with
    Class::C3::XS installed (which is an optional prereq of Class::C3,
    which is in turn a prereq of this package), but it's not a requirement.
    
    This module never exports any functions. All calls must be fully
    qualified with the mro:: prefix.
Something went wrong with that request. Please try again.