Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Commits on Mar 23, 2007
  1. Creating branch jlam-pkgviews

    cvs authored
  2. add nspluginwrapper

    abs authored
  3. Update ns-flash to 9.0.31nb1:

    abs authored
        - Add a nspluginwrapper option (enabled by default on non Linux x86
          platforms) which pulls in nspluginwrapper and libflashsupport, and
          enables a INSTALL script which enables the plugin wrapper
    
    Copy of note in options.mk:
    # XXXX: If nspluginwrapper is enabled and this package is installed after
    # firefox (or similar) it will install a system wide wrapped plugin into
    # @PREFIX/lib/<browser>/plugins. If it is installed before a browser
    # it will install a plugin for the current user in ~/.mozilla/plugins/
    # or similar. This is inconsistant and potentially confusing.
  4. import transset-df, a modification of xorg's transset, to set window

    drochner authored
    transparancy, mostly used together with xcompmgr
  5. update to 0.3.7

    drochner authored
    changes:
    * The background of the window in the standard theme is now just slightly
      transparent when compiled against GTK+ 2.10 and when using a composite
      manager.
    -initial accessibility support
    -bugfixes
  6. update to 1.2.8

    drochner authored
    change:
    This release introduces a changed internal item lookup handling that
    changes linear list searches to two step hash map lookups. While this
    might improve performance it also can introduce new instabilities.
  7. make this build with new gnome-doc-utils

    drochner authored
  8. Needs msgfmt.

    joerg authored
  9. - texmaker-1.5.

    ghen authored
  10. Updated editors/texmaker to 1.5.

    ghen authored
  11. Update to texmaker-1.5.

    ghen authored
    * A summary of the latex errors and warnings is displayed before the
      full log file.
    * A "most used symbols" panel has been added.
    * The math mode "$$...$$" has been replaced by "\[ \]".
    * The colors for the syntax highlighting can now be modified.
    * The current line number can be added to the latex related commands.
    * Some bugs has been fixed (dialogs layout, french translation...)
  12. Sort includes.

    hira authored
  13. Explicitly include bl3.mk files of cairo and MesaLib.

    hira authored
    This fixes build with modular X.Org.
  14. note update of textproc/icu to 3.6

    recht authored
  15. update to ICU 3.6

    recht authored
    Major changes in ICU 3.6 include the following:
    -	Unicode: ICU uses and supports Unicode 5.0, which is the latest major release of Unicode. Unicode 5.0 will be used in many operating systems and applications, and this version of ICU is important maintain interoperability with these new operating systems and applications. More information about Unicode 5.0 can be found in the Unicode press release.
    -	Locale Data: ICU uses and supports data from Common Locale Data Repository (CLDR) 1.4, which includes many improvements in quality and quantity of data. There is 25% more CLDR locale data in 245 locales in ICU.
    -	ICU4C Specific Changes
    -	Charset Detection: A charset detection framework was added, which provides heuristics for detecting the charset for unlabeled sequences of bytes.
    -	Layout: The font layout engine has support added for Tibetan, Sinhala and Old Hangul.
    -	BiDi: The BiDi algorithm was enhanced to be more flexible and efficient
    -	ICU Data Management: The new icupkg tool provides an easier way to manage ICU's data library. This tool allows you to add, update or remove data from ICU's data archive.
    -	Time Zones The time zone data is modularized to allow easier building and updating of the data.
    -	Word Boundaries: The Thai word break iteration was improved to be more accurate. Also dictionary based detection of Thai word boundaries is now active for all locales.
    -	UText
    -	The BreakIterator uses UText for abstract text processing.
    -	64-bit indexing is now used to allow access to larger chunks of text.
    -	API for read-only locking for security and robustness was added.
    -	Performance
    -	The u_sprintf/u_sscanf performance from the icuio library has been improved for number formatting/parsing.
    -	Constructing a DateFormat is significantly faster for many locales.
    -	Opening and closing a charset converter is significantly faster.
    -	The UTF-8 transformation functions and macros are faster.
    -	The UText API was improved for performance.
    -	The collation open and close functions have a small performance improvement.
  16. Fix typos in options.mk

    adrianp authored
    Fix snort-flexresp{2} so that they actually can be tested and work properly
     with the new libnet{10,11} laoyout
    Pointed out by wiz@ in private email
  17. USE_TOOLS+=pkg-config.

    hira authored
  18. Add checksums for patch-ak and patch-bd.

    wiz authored
  19. Remove unused patch.

    wiz authored
  20. Mention move of chat/ser to net/ser.

    wiz authored
  21. Reimport chat/ser as net/ser, since that's a better fit.

    wiz authored
    Addresses PR 36059.
  22. note update of mail/wl to 2.14.0nb5

    jnemeth authored
  23. Added back elmo-shimbun and added a dependency on www/emacs-w3m.

    jnemeth authored
    The elmo-shimbun files are conditionally installed based on whether
    the emacs-w3m package is found on the system.
    
    XXX The dependency on emacs-w3m should really be turned into an
    option and have the installation of the elmo-shimbun files depend
    on it; however, this change prevents nasty surprises for those that
    do have it (i.e. people using editors/emacs-packages).
Commits on Mar 22, 2007
  1. add note on how to use the Linux flash player into a native Firefox b…

    abs authored
    …rowser on a system other than 32 bit Linux
  2. Added multimedia/libflashsupport version 1.0.2098 [abs 2007-03-22]

    abs authored
    Added www/nspluginwrapper version 0.9.91.3 [abs 2007-03-22]
    
    
    nspluginwrapper is an Open Source compatibility plugin for Netscape
    4 (NPAPI) plugins. It separates the execution environment of the
    plugin from the browser, allowing a plugin compiled for one ABI to
    be used in a browser compiled for another.
    
    For example the linux 32bit Adobe Flash plugin can be used in a
    native Firefox under Linux/x86_64, NetBSD and FreeBSD platforms.
    
    To install the Linux flash player into a native Firefox browser:
      - Also install multimedia/ns-flash and multimedia/libflashsupport
      - Run "nspluginwrapper -i /usr/pkg/lib/netscape/plugins/libflashplayer.so"
      - Run Firefox
    
    This is working at least under NetBSD/i386 4.0_BETA with native and modular
    x11.
  3. enable nspluginwrapper

    abs authored
  4. Import www/nspluginwrapper-0.9.91.3 into pkgsrc:

    abs authored
    nspluginwrapper is an Open Source compatibility plugin for Netscape
    4 (NPAPI) plugins. It separates the execution environment of the
    plugin from the browser, allowing a plugin compiled for one ABI to
    be used in a browser compiled for another.
    
    For example the linux 32bit Adobe Flash plugin can be used in a
    native Firefox under Linux/x86_64, NetBSD and FreeBSD platforms.
    
    To install the Linux flash player into a native Firefox browser:
      - Also install multimedia/ns-flash and multimedia/libflashsupport
      - Run "nspluginwrapper -i /usr/pkg/lib/netscape/plugins/libflashplayer.so"
      - Run Firefox
    
    This is working at least under NetBSD/i386 4.0_BETA with native and modular
    x11.
  5. note update of www/py-curl to 7.16.1

    recht authored
  6. update to pycurl-7.16.1

    recht authored
    Version 7.16.1 [requires libcurl-7.16.1 or better]
    --------------
    
            * Added constants for all libcurl (error) return codes.  They
              are named the same as the macro constants in curl.h but prefixed
              with E_ instead of CURLE.  Return codes for the multi API are
              prefixed with M_ instead of CURLM.
    
            * Added CURLOPT_FTP_SSL_CCC, CURLOPT_SSH_PUBLIC_KEYFILE,
              CURLOPT_SSH_PRIVATE_KEYFILE, CURLOPT_SSH_AUTH_TYPES.
    
            * Removed CLOSEPOLICY and friends since this option is now
              deprecated in libcurl.
    
            * Set the _use_datetime attribute on the CURLTransport class
              to unbreak xmlrpc_curl.py on Python 2.5.
    
    
    Version 7.16.0 [no public release]
    --------------
    
            * Added CURLOPT_SSL_SESSIONID_CACHE.
    
            * Removed SOURCE_* options since they are no longer
              supported by libcurl.
    
    
    Version 7.15.5.1
    ----------------
    
            * Added test for basic ftp usage (tests/test_ftp.py).
    
            * Fix broken ssl mutex lock function when using
              GNU TLS (Debian bug #380156, fix by Bastian Kleineidam)
    
    
    Version 7.15.5
    --------------
    
            * Added CURLOPT_FTP_ALTERNATIVE_TO_USER,
              CURLOPT_MAX_SEND_SPEED_LARGE,
              and CURLOPT_MAX_RECV_SPEED_LARGE.
    
    
    Version 7.15.4.2
    ----------------
    
            * Use SSL locking callbacks, fixes random
              crashes for multithreaded SSL connections
              (patch by Jayne <corvine at gmail.com>).
    
    
    Version 7.15.4.1
    ----------------
    
            * Fixed compilation problem with C compilers
              not allowing declarations in the middle of
              code blocks (patch by
              K.S.Sreeram <sreeram at tachyontech.net>).
    
            * Fixed bug in curl_multi_fdset wrapping,
              max_fd < 0 is not an error (patch by
              K.S.Sreeram <sreeram at tachyontech.net>).
    
    
    Version 7.15.4
    --------------
    
            * Added support for libcurl shares, patch from
            Victor Lascurain <bittor at eleka.net>.  See the
            file tests/test_share.py for example usage.
    
            * Added support for CURLINFO_FTP_ENTRY_PATH.
    
    
    Version 7.15.2
    --------------
    
            * Added CURLOPT_CONNECT_ONLY, CURLINFO_LASTSOCKET,
              CURLOPT_LOCALPORT and CURLOPT_LOCALPORTRANGE.
    
    
    Version 7.15.1
    --------------
    
    2006-01-31 Kjetil Jacobsen <kjetilja>
    
            * Fixed memory leak for getinfo calls that return a
              list as result.  Patch by Paul Pacheco.
    
    
    Version 7.15.0
    --------------
    
    2005-10-18  Kjetil Jacobsen  <kjetilja>
    
            * Added CURLOPT_FTP_SKIP_PASV_IP.
    
    
    Version 7.14.1
    --------------
    
    2005-09-05  Kjetil Jacobsen  <kjetilja>
    
            * Added CURLOPT_IGNORE_CONTENT_LENGTH, CURLOPT_COOKIELIST as
              COOKIELIST and CURLINFO_COOKIELIST as INFO_COOKIELIST.
    
    
    Version 7.14.0
    --------------
    
    2005-05-18  Kjetil Jacobsen  <kjetilja>
    
            * Added missing information returned from the info() method
              in the high-level interface.
    
            * Added the FORM_FILENAME option to the CURLFORM API
              with HTTPPOST.
    
    
    Version 7.13.2
    --------------
    
    2005-03-30  Kjetil Jacobsen  <kjetilja>
    
            * Unbreak tests/test_gtk.py and require pygtk >= 2.0.
    
    2005-03-15  Kjetil Jacobsen  <kjetilja>
    
            * Cleaned up several of the examples.
    
    2005-03-11  Kjetil Jacobsen  <kjetilja>
    
            * WARNING: multi.select() now requires the previously optional
              timeout parameter.  Updated the tests and examples to reflect
              this change.  If the timeout is not set, select could block
              infinitely and cause problems for the internal timeout handling
              in the multi stack.  The problem was identified by
              <unknownsoldier93 at yahoo.com>.
    
    
    Version 7.13.1
    --------------
    
    2005-03-04  Kjetil Jacobsen  <kjetilja>
    
            * Use METH_NOARGS where appropriate.
    
    2005-03-03  Kjetil Jacobsen  <kjetilja>
    
            * Added support for CURLFORM API with HTTPPOST: Supports a
              a tuple with pairs of options and values instead of just
              supporting string contents.  See tests/test_post2.py
              for example usage.  Options are FORM_CONTENTS, FORM_FILE and
              FORM_CONTENTTYPE, corresponding to the CURLFORM_* options,
              and values are strings.
    
    2005-02-13  Markus F.X.J. Oberhumer <mfx>
    
            * Read callbacks (pycurl.READFUNCTION) can now return
              pycurl.READFUNC_ABORT to immediately abort the current transfer.
    
            * The INFILESIZE, MAXFILESIZE, POSTFIELDSIZE and RESUME_FROM
              options now automatically use the largefile version to handle
              files > 2GB.
    
            * Added missing pycurl.PORT constant.
    
    
    Version 7.13.0
    --------------
    
    2005-02-10  Kjetil Jacobsen  <kjetilja>
    
            * Added file_upload.py to examples, shows how to upload
              a file.
    
            * Added CURLOPT_IOCTLFUNCTION/DATA.
    
            * Added options from libcurl 7.13.0: FTP_ACCOUNT, SOURCE_URL,
              SOURCE_QUOTE.
    
            * Obsoleted options: SOURCE_HOST, SOURCE_PATH, SOURCE_PORT,
              PASV_HOST.
    
    
    Version 7.12.3
    --------------
    
    2004-12-22  Markus F.X.J. Oberhumer <mfx>
    
            * Added CURLINFO_NUM_CONNECTS and CURLINFO_SSL_ENGINES.
    
            * Added some other missing constants.
    
            * Updated pycurl.version_info() to return a 12-tuple
              instead of a 9-tuple.
    
    
    Version 7.12.2
    --------------
    
    2004-10-15  Kjetil Jacobsen  <kjetilja>
    
            * Added CURLOPT_FTPSSLAUTH (and CURLFTPAUTH_*).
    
            * Added CURLINFO_OS_ERRNO.
    
    2004-08-17 Kjetil Jacobsen <kjetilja>
    
            * Use LONG_LONG instead of PY_LONG_LONG to make pycurl compile
              on Python versions < 2.3 (fix from Domenico Andreoli
              <cavok at libero.it>).
  7. enable libflashsupport

    abs authored
  8. Import multimedia/libflashsupport-1.0.2098

    abs authored
    This is an shared library built from source provided by Adobe which
    enables the use of OSS audio in the multimedia/ns-flash package
    
    Non Linux platforms will probably also need www/nspluginwrapper
  9. Updated wm/fluxbox to 1.0rc3

    xtraeme authored
Something went wrong with that request. Please try again.