Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master
Fetching contributors…

Cannot retrieve contributors at this time

245 lines (236 sloc) 6.288 kb
--- !ruby/object:Gem::Specification
name: authlogic-connect
version: !ruby/object:Gem::Version
hash: 19
prerelease: false
segments:
- 0
- 0
- 18
version: 0.0.18
platform: ruby
authors:
- Lance Pollard
autorequire:
bindir: bin
cert_chain: []
date: 2010-07-14 00:00:00 -07:00
default_executable:
dependencies:
- !ruby/object:Gem::Dependency
name: activesupport
prerelease: false
requirement: &id001 !ruby/object:Gem::Requirement
none: false
requirements:
- - ">="
- !ruby/object:Gem::Version
hash: 15
segments:
- 2
- 1
- 2
version: 2.1.2
type: :runtime
version_requirements: *id001
- !ruby/object:Gem::Dependency
name: activerecord
prerelease: false
requirement: &id002 !ruby/object:Gem::Requirement
none: false
requirements:
- - ">="
- !ruby/object:Gem::Version
hash: 15
segments:
- 2
- 1
- 2
version: 2.1.2
type: :runtime
version_requirements: *id002
- !ruby/object:Gem::Dependency
name: json
prerelease: false
requirement: &id003 !ruby/object:Gem::Requirement
none: false
requirements:
- - ">="
- !ruby/object:Gem::Version
hash: 3
segments:
- 0
version: "0"
type: :runtime
version_requirements: *id003
- !ruby/object:Gem::Dependency
name: ruby-openid
prerelease: false
requirement: &id004 !ruby/object:Gem::Requirement
none: false
requirements:
- - ">="
- !ruby/object:Gem::Version
hash: 3
segments:
- 0
version: "0"
type: :runtime
version_requirements: *id004
- !ruby/object:Gem::Dependency
name: rack-openid
prerelease: false
requirement: &id005 !ruby/object:Gem::Requirement
none: false
requirements:
- - ">="
- !ruby/object:Gem::Version
hash: 21
segments:
- 0
- 2
- 1
version: 0.2.1
type: :runtime
version_requirements: *id005
- !ruby/object:Gem::Dependency
name: oauth
prerelease: false
requirement: &id006 !ruby/object:Gem::Requirement
none: false
requirements:
- - ">="
- !ruby/object:Gem::Version
hash: 3
segments:
- 0
version: "0"
type: :runtime
version_requirements: *id006
- !ruby/object:Gem::Dependency
name: oauth2
prerelease: false
requirement: &id007 !ruby/object:Gem::Requirement
none: false
requirements:
- - ">="
- !ruby/object:Gem::Version
hash: 3
segments:
- 0
version: "0"
type: :runtime
version_requirements: *id007
- !ruby/object:Gem::Dependency
name: authlogic
prerelease: false
requirement: &id008 !ruby/object:Gem::Requirement
none: false
requirements:
- - ">="
- !ruby/object:Gem::Version
hash: 3
segments:
- 0
version: "0"
type: :runtime
version_requirements: *id008
description: Oauth and OpenID made dead simple
email: lancejpollard@gmail.com
executables: []
extensions: []
extra_rdoc_files: []
files:
- README.markdown
- Rakefile
- init.rb
- MIT-LICENSE
- lib/authlogic-connect.rb
- lib/authlogic_connect/access_token.rb
- lib/authlogic_connect/authlogic_connect.rb
- lib/authlogic_connect/callback_filter.rb
- lib/authlogic_connect/common/session.rb
- lib/authlogic_connect/common/state.rb
- lib/authlogic_connect/common/user.rb
- lib/authlogic_connect/common/variables.rb
- lib/authlogic_connect/common.rb
- lib/authlogic_connect/engine.rb
- lib/authlogic_connect/ext.rb
- lib/authlogic_connect/oauth/helper.rb
- lib/authlogic_connect/oauth/process.rb
- lib/authlogic_connect/oauth/session.rb
- lib/authlogic_connect/oauth/state.rb
- lib/authlogic_connect/oauth/tokens/aol_token.rb
- lib/authlogic_connect/oauth/tokens/facebook_token.rb
- lib/authlogic_connect/oauth/tokens/foursquare_token.rb
- lib/authlogic_connect/oauth/tokens/get_satisfaction_token.rb
- lib/authlogic_connect/oauth/tokens/github_token.rb
- lib/authlogic_connect/oauth/tokens/google_token.rb
- lib/authlogic_connect/oauth/tokens/linked_in_token.rb
- lib/authlogic_connect/oauth/tokens/meetup_token.rb
- lib/authlogic_connect/oauth/tokens/myspace_token.rb
- lib/authlogic_connect/oauth/tokens/netflix_token.rb
- lib/authlogic_connect/oauth/tokens/oauth_token.rb
- lib/authlogic_connect/oauth/tokens/ohloh_token.rb
- lib/authlogic_connect/oauth/tokens/opensocial_token.rb
- lib/authlogic_connect/oauth/tokens/twitter_token.rb
- lib/authlogic_connect/oauth/tokens/vimeo_token.rb
- lib/authlogic_connect/oauth/tokens/yahoo_token.rb
- lib/authlogic_connect/oauth/user.rb
- lib/authlogic_connect/oauth/variables.rb
- lib/authlogic_connect/oauth.rb
- lib/authlogic_connect/openid/process.rb
- lib/authlogic_connect/openid/session.rb
- lib/authlogic_connect/openid/state.rb
- lib/authlogic_connect/openid/tokens/aol_token.rb
- lib/authlogic_connect/openid/tokens/blogger_token.rb
- lib/authlogic_connect/openid/tokens/flickr_token.rb
- lib/authlogic_connect/openid/tokens/my_openid_token.rb
- lib/authlogic_connect/openid/tokens/openid_token.rb
- lib/authlogic_connect/openid/user.rb
- lib/authlogic_connect/openid/variables.rb
- lib/authlogic_connect/openid.rb
- lib/authlogic_connect/rack_state.rb
- lib/open_id_authentication.rb
- rails/init.rb
- test/controllers/test_users_controller.rb
- test/database.yml
- test/libs/database.rb
- test/libs/user.rb
- test/libs/user_session.rb
- test/test_helper.rb
- test/test_oauth.rb
- test/test_openid.rb
- test/test_user.rb
has_rdoc: true
homepage: http://github.com/viatropos/authlogic-connect
licenses: []
post_install_message:
rdoc_options: []
require_paths:
- lib
required_ruby_version: !ruby/object:Gem::Requirement
none: false
requirements:
- - ">="
- !ruby/object:Gem::Version
hash: 3
segments:
- 0
version: "0"
required_rubygems_version: !ruby/object:Gem::Requirement
none: false
requirements:
- - ">="
- !ruby/object:Gem::Version
hash: 3
segments:
- 0
version: "0"
requirements: []
rubyforge_project: authlogic-connect
rubygems_version: 1.3.7
signing_key:
specification_version: 3
summary: "Authlogic Connect: Oauth and OpenID made dead simple"
test_files: []
Jump to Line
Something went wrong with that request. Please try again.