Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Performance/Workers] Slow performance when saving worker editor with many roles/groups #1139

Closed
jstanden opened this issue Jan 9, 2020 · 1 comment
Labels
bug
Projects
Milestone

Comments

@jstanden
Copy link
Owner

@jstanden jstanden commented Jan 9, 2020

This is likely caused by the role roster and saved search invalidations.

@jstanden jstanden created this issue from a note in 9.4.9 (TODO) Jan 9, 2020
@jstanden jstanden moved this from TODO to Bugs in 9.4.9 Jan 9, 2020
@jstanden jstanden added the bug label Jan 9, 2020
@jstanden jstanden added this to the 9.4.7 milestone Jan 9, 2020
@jstanden

This comment has been minimized.

Copy link
Owner Author

@jstanden jstanden commented Jan 10, 2020

Fixed in 9.4.7

@jstanden jstanden closed this Jan 10, 2020
9.4.9 automation moved this from Bugs to Completed! Jan 10, 2020
jstanden added a commit that referenced this issue Jan 10, 2020
…hen saving worker and group editors. This had to do with recent changes to role cache invalidation, which used an inefficient strategy.

Fixes #1139
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
9.4.9
  
Completed!
1 participant
You can’t perform that action at this time.