New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Bots/Behaviors] Condition stops saving after clearing/adding workers in 'message sender worker id' conditions on 'new message' behaviors #834

Closed
jstanden opened this Issue Dec 14, 2018 · 1 comment

Comments

Projects
1 participant
@jstanden
Copy link
Owner

jstanden commented Dec 14, 2018

No description provided.

@jstanden jstanden created this issue from a note in 9.1.3 (In Development) Dec 14, 2018

@jstanden jstanden added this to the 9.0.9 milestone Dec 14, 2018

@jstanden jstanden added the bug label Dec 14, 2018

@jstanden

This comment has been minimized.

Copy link
Owner

jstanden commented Dec 14, 2018

Introduced in 2010. Slayed the lich in 9.0.9

@jstanden jstanden closed this Dec 14, 2018

9.1.3 automation moved this from In Development to Completed! Dec 14, 2018

jstanden added a commit to wgm/cerb that referenced this issue Dec 14, 2018

* [Bots/Behaviors] Fixed an ancient issue in bot behaviors that used …
…worker-based conditions. When removing a worker from the chooser, it was possible to enter a state where no changes to the condition could be saved until it was deleted and re-added.

Fixes jstanden#834
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment