Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Unable to authenticate with APOP #539

Closed
yadavmukul1986 opened this issue Jul 13, 2017 · 5 comments
Closed

Unable to authenticate with APOP #539

yadavmukul1986 opened this issue Jul 13, 2017 · 5 comments

Comments

@yadavmukul1986
Copy link

@yadavmukul1986 yadavmukul1986 commented Jul 13, 2017

Hi jstedfast,

I am facing the same problem at one of my clients. I have checked out latest Mailkit version (1.16). Client Email Server is APOP. Screens are attached for your reference. Command prompt displayed is from my windows application and text file is from Protocol Logger, enabled in MailKit. I have made following change for APOP -

client.AuthenticationMechanisms.Remove("XOAUTH2");
client.AuthenticationMechanisms.Remove("APOP");

Please suggest how to do an APOP from mailkit as i am stuck now.

apop

@jstedfast

This comment has been minimized.

Copy link
Owner

@jstedfast jstedfast commented Jul 13, 2017

The latest is 1.16.2 and has an APOP fix, please upgrade and try again.

@jstedfast jstedfast closed this Jul 13, 2017
@jstedfast

This comment has been minimized.

Copy link
Owner

@jstedfast jstedfast commented Jul 13, 2017

BTW, the problem is that your server is disconnecting after a failed APOP authentication attempt.

Also, as the docs explain, to disable APOP authentication, do this:

client.Capabilities &= ~Pop3Capabilities.Apop;
@yadavmukul1986

This comment has been minimized.

Copy link
Author

@yadavmukul1986 yadavmukul1986 commented Jul 14, 2017

Thank you so much, that was very quick. I'l try as suggested.

It Worked with version 1.16.0 after i added below line -

client.Capabilities &= ~MailKit.Net.Pop3.Pop3Capabilities.Apop;

however the updated version (1.16.2) didn't work for me until i added above line.

@jstedfast

This comment has been minimized.

Copy link
Owner

@jstedfast jstedfast commented Jul 14, 2017

Then it probably means that your POP3 server doesn't properly implement APOP support :\

@yadavmukul1986

This comment has been minimized.

Copy link
Author

@yadavmukul1986 yadavmukul1986 commented Jul 15, 2017

Ok. Thanks for the information.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.