João Duarte
jsvd

  • elastic
  • Portugal
  • Joined on Oct 30, 2008

Organizations

@elastic
Jul 21, 2016
@jsvd
Jul 21, 2016
jsvd commented on pull request elastic/logstash#5560
@jsvd

@guy I merely copied a portion of your Batch API, I'm not suggesting append instead of add. Going along Colin's argument, I think there's value in …

Jul 21, 2016
jsvd commented on pull request elastic/logstash#5560
@jsvd

I see some confusion in explaining in one sentence what the add(event) api does from the outside perspective (the implementation is irrelevant): #a…

jsvd deleted branch fix_lock_conflicts at jsvd/logstash
Jul 21, 2016
Jul 21, 2016
jsvd commented on pull request elastic/logstash#5641
@jsvd

One question, if we backport this to 2.4, we'll have to add this as command line flag, since the yaml configuration for settings has only been intr…

Jul 21, 2016
@jsvd
  • @guyboertje 1002d50
    Implementation - Java Event type casting conversion optimization (#4999)
  • @purbon b0e1ded
    move the payload filter to the respond_with method helper
  • 21 more commits »
Jul 21, 2016
jsvd commented on issue elastic/logstash#5652
@jsvd

I'm all for option 1, for the stated reasons that, if the consumers are faster than producers, then you want to lower latency as much as possible. T…

Jul 21, 2016
jsvd commented on pull request elastic/logstash#5641
@jsvd

@suyograo I believe you meant to say default abort_on_error to true, and users can turn it off if they want.

Jul 21, 2016
@jsvd

Missing the templates :)

Jul 20, 2016
jsvd opened pull request elastic/logstash#5669
@jsvd
update fpm and clamp to remove .lock conflits
1 commit with 30 additions and 15 deletions
Jul 20, 2016
Jul 20, 2016
@jsvd
choose default template based on es version
1 commit with 61 additions and 5 deletions
Jul 19, 2016
jsvd commented on issue elastic/logstash#5648
@jsvd

We've decided to go ahead with: 2) upgrade the fpm dependency in the Gemfile to gem "fpm", "~> 1.6.3" (equivalent to 1.6.x + bigger than or equal t…

Jul 19, 2016
jsvd commented on pull request elastic/logstash#5521
@jsvd

LGTM

Jul 19, 2016
@jsvd
Mass update plugins gemspec so 5.x plugins can be installed on LS 2.4 and above
Jul 19, 2016
jsvd commented on issue elastic/logstash#5496
@jsvd

All plugins that where plugin api v2 compatible have already been published. Now that i think about it, I think it's safe to close this as done.

Jul 19, 2016
@jsvd

any reason for the removal of the timestap_field feature?

Jul 19, 2016
jsvd commented on issue elastic/logstash#5648
@jsvd

The main reason json v2.x.x gets installed is from the json dependencies of: coveralls: json < 3, >= 1.8 simplecov: json < 3, >= 1.8 fpm 1.3.x: j…

Jul 19, 2016
@jsvd
new major version of json gem breaks default plugin installation rake task
Jul 19, 2016
@jsvd
Update document
Jul 19, 2016
jsvd commented on pull request logstash-plugins/logstash-filter-csv#26
@jsvd

this has already been fixed. nevertheless thank you for the contribution :)

Jul 19, 2016
@jsvd
fixes csv convert example
Jul 19, 2016
jsvd commented on pull request logstash-plugins/logstash-filter-csv#35
@jsvd

this has already been fixed. nevertheless, thank you for the contribution :)

jsvd deleted branch markwalkom-convertdocpatch at logstash-plugins/logstash-filter-csv
Jul 19, 2016
Jul 19, 2016
@jsvd
Add default plugins to master Gemfile
Jul 19, 2016
@jsvd
Travis Build failing for 5.0