Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

On Dev branch - 'StarClusterConfig' object has no attribute 'get_cluster_names' #183

Closed
JohnCEarls opened this Issue · 0 comments

2 participants

@JohnCEarls

I was just checking the dev branch to confirm 3569501 and when I tried to run
starcluster start -o -s 1 -b .5 -i m1.large -n ami-de8f31b7 imagehost
I got the following error:

Traceback (most recent call last):
File "/usr/local/bin/starcluster", line 9, in
load_entry_point('StarCluster==0.9999', 'console_scripts', 'starcluster')()
File "/usr/local/lib/python2.6/dist-packages/StarCluster-0.9999-py2.6.egg/starcluster/cli.py", line 312, in main
StarClusterCLI().main()
File "/usr/local/lib/python2.6/dist-packages/StarCluster-0.9999-py2.6.egg/starcluster/cli.py", line 250, in main
gopts, sc, opts, args = self.parse_subcommands()
File "/usr/local/lib/python2.6/dist-packages/StarCluster-0.9999-py2.6.egg/starcluster/cli.py", line 91, in parse_subcommands
sc.addopts(lparser)
File "/usr/local/lib/python2.6/dist-packages/StarCluster-0.9999-py2.6.egg/starcluster/commands/start.py", line 38, in addopts
templates = self.cfg.get_cluster_names().keys()
AttributeError: 'StarClusterConfig' object has no attribute 'get_cluster_names'

I ran clean.py and rm -r'd the previous install, if that helps.
Thanks.

@jtriley jtriley closed this in dd05d7a
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.