Client Compatibility and Documentation

Kenichi Maehashi edited this page Dec 26, 2016 · 63 revisions
Clone this wiki locally

Each Jubatus versions are compatible with the following versions of the client library. You can also download the HTML documentation (snapshot of the website) for the version.

Jubatus Client Documentation
Python Ruby Java Go
1.0.1 1.0.0 1.0.0 1.0.0 1.0.0 Online
1.0.0 1.0.0
0.9.4 0.9.1 0.9.1 0.9.1 0.9.1 0.9.4
0.9.3 0.9.3
0.9.2 0.9.2
0.9.1 0.9.1
0.9.0 0.9.0 0.9.0 0.9.0 0.9.0 0.9.0
0.8.9 0.8.2 0.8.0 0.8.0 0.8.0 0.8.9
0.8.8 0.8.8
0.8.7 0.8.7
0.8.6 0.8.6
0.8.5 0.8.5
0.8.4 0.8.4
0.8.3 0.8.3
0.8.2 0.8.2
0.8.1 0.8.1 0.8.1
0.8.0 0.8.0 0.8.0
0.7.2 0.7.1 0.7.1 0.7.1 0.7.1 0.7.2
0.7.1 0.7.1
0.7.0 0.7.0 0.7.0 0.7.0 0.7.0 0.7.0
0.6.6 0.6.1 0.6.2 0.6.1 - 0.6.6
0.6.5 0.6.5
0.6.4 0.6.4
0.6.3 0.6.0 0.6.1 0.6.0 0.6.3
0.6.2 0.6.2
0.6.1 0.6.1
0.6.0 0.6.0 0.6.0
0.5.4 0.5.4 0.5.4 0.5.3 0.5.4
0.5.3 0.5.2 0.5.3 0.5.2 0.5.3
0.5.2 0.5.1 0.5.2 0.5.1 0.5.2
0.5.1 0.5.1
0.5.0 0.5.0 0.5.1 0.5.0 0.5.0
0.4.5 0.4.1 0.4.1 0.4.2 0.4.5
0.4.4 0.4.4
0.4.3 0.4.3
0.4.2 0.4.2
0.4.1 0.4.0-p1 0.4.0 0.4.1 0.4.1
0.4.0 0.4.0 0.4.0
0.3.4 0.3.1-p1 0.1.0 0.3.2 0.3.4
0.3.3 0.3.3
0.3.2 0.3.2

Older client libraries are available via our download site (not supported).

Jubakit

  • Jubakit 0.2.0 or later is compatibile with Jubatus 0.8.0 or later. Anomaly service requires Jubatus 0.9.0 or later. Weight service requires Jubatus 0.9.1 or later. Regression and Clustering service requires Jubatus 1.0.0 or later.
  • Jubakit 0.1.0 is compatibile with Jubatus 0.8.0 or later.