Skip to content
Browse files

bundlerize

  • Loading branch information...
1 parent f71748c commit 1035dbb4128abf81893bb04e0ca61d9a0c7c5dc2 @jugyo committed
Showing with 19 additions and 33 deletions.
  1. +4 −0 Gemfile
  2. +1 −18 Rakefile
  3. +0 −1 VERSION
  4. +14 −14 g.gemspec
View
4 Gemfile
@@ -0,0 +1,4 @@
+source "http://rubygems.org"
+
+# Specify your gem's dependencies in g.gemspec
+gemspec
View
19 Rakefile
@@ -1,21 +1,4 @@
-require 'rubygems'
-require 'rake'
-
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = "g"
- gem.summary = %Q{g is like p}
- gem.description = %Q{The Kernel.g that works like Kernel.p on growl :)}
- gem.email = "jugyo.org@gmail.com"
- gem.homepage = "http://github.com/jugyo/g"
- gem.authors = ["jugyo"]
- gem.add_development_dependency "rspec", ">= 0"
- gem.add_dependency "ruby_gntp", ">= 1.0.1"
- end
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: sudo gem install jeweler"
-end
+require "bundler/gem_tasks"
require 'rspec/core'
require 'rspec/core/rake_task'
View
1 VERSION
@@ -1 +0,0 @@
-1.3.0
View
28 g.gemspec
@@ -1,16 +1,16 @@
+# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
- s.name = 'g'
- s.version = '1.2.0'
- s.summary = "The Kernel.g that works like Kernel.p on growl :)"
- s.description = "The Kernel.g that works like Kernel.p on growl :)"
- s.files = %w( lib/g.rb
- spec/g_spec.rb
- README.markdown
- Rakefile )
- s.add_dependency("ruby-growl", ">= 1.0.1")
- s.author = 'jugyo'
- s.email = 'jugyo.org@gmail.com'
- s.homepage = 'http://github.com/jugyo/g'
- s.rubyforge_project = 'kernelg'
- s.has_rdoc = false
+ s.name = "g"
+ s.version = "1.3.0"
+ s.authors = ["jugyo"]
+ s.email = ["jugyo.org@gmail.com"]
+ s.homepage = "http://github.com/jugyo/g"
+ s.summary = %q{The Kernel.g}
+ s.description = %q{It works like Kernel.p with growl :)}
+ s.rubyforge_project = "g"
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ["lib"]
+ s.add_runtime_dependency "ruby_gntp"
end

0 comments on commit 1035dbb

Please sign in to comment.
Something went wrong with that request. Please try again.