Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

The promptscript property is broken on JDK 15 and higher #394

Open
julianhyde opened this issue Oct 18, 2020 · 1 comment
Open

The promptscript property is broken on JDK 15 and higher #394

julianhyde opened this issue Oct 18, 2020 · 1 comment

Comments

@julianhyde
Copy link
Owner

@julianhyde julianhyde commented Oct 18, 2020

The promptscript property, added in #278, is broken in JDK 15 and higher. The implementation requires the Nashorn JavaScript engine, which was removed in JDK 15. The error is as follows:

java.lang.NullPointerException: Cannot invoke "javax.script.ScriptEngine.eval(String, javax.script.Bindings)" because "engine" is null

A possible fix would be to use an alternative scripting engine, which would need to be added to the classpath.

@snuyanzin
Copy link
Collaborator

@snuyanzin snuyanzin commented Oct 21, 2020

We could use property to store scripting engine to use. In case there is no specified engine - print a message.
+ may be to have something similar to !scan to show available scripting engines

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants