Permalink
Browse files

first steps towards gemifying.

  • Loading branch information...
1 parent 9e9fed5 commit 5da33c91ba2cccae33ae618b2975a14d82261ec2 @jerodsanto jerodsanto committed Apr 14, 2009
Showing with 56 additions and 2 deletions.
  1. +1 −0 .gitignore
  2. +13 −0 Rakefile
  3. +2 −2 VERSION.yml
  4. +40 −0 rack-noie6.gemspec
View
@@ -0,0 +1 @@
+pkg/*
View
@@ -5,4 +5,17 @@ task :default => [:test]
Rake::TestTask.new do |task|
task.pattern = 'test/noie6_test.rb'
task.warning, task.verbose = true, true
+end
+
+begin
+ require 'jeweler'
+ Jeweler::Tasks.new do |gemspec|
+ gemspec.name = "rack-noie6"
+ gemspec.summary = "A Rack middleware to redirect IE6 users out of your website"
+ gemspec.email = "jerod.santo@gmail.com"
+ gemspec.homepage = "http://github.com/sant0sk1/rack-noie6"
+ gemspec.authors = ["Jerod Santo", "Julio Cesar Ody"]
+ end
+rescue LoadError
+ puts "Jeweler not available. Install it with: sudo gem install technicalpickles-jeweler -s http://gems.github.com"
end
View
@@ -1,4 +1,4 @@
---
-:patch: 0
-:major: 0
+:major: 1
:minor: 0
+:patch: 0
View
@@ -0,0 +1,40 @@
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = %q{rack-noie6}
+ s.version = "1.0.0"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.authors = ["Jerod Santo", "Julio Cesar Ody"]
+ s.date = %q{2009-04-14}
+ s.email = %q{jerod.santo@gmail.com}
+ s.extra_rdoc_files = [
+ "README.markdown"
+ ]
+ s.files = [
+ "README.markdown",
+ "Rakefile",
+ "VERSION.yml",
+ "lib/noie6.rb",
+ "test/noie6_test.rb"
+ ]
+ s.has_rdoc = true
+ s.homepage = %q{http://github.com/sant0sk1/rack-noie6}
+ s.rdoc_options = ["--charset=UTF-8"]
+ s.require_paths = ["lib"]
+ s.rubygems_version = %q{1.3.1}
+ s.summary = %q{A Rack middleware to redirect IE6 users out of your website}
+ s.test_files = [
+ "test/noie6_test.rb"
+ ]
+
+ if s.respond_to? :specification_version then
+ current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
+ s.specification_version = 2
+
+ if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ else
+ end
+ else
+ end
+end

0 comments on commit 5da33c9

Please sign in to comment.