Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

1.5.0,urllib3版本冲突问题 #2771

Open
wonxin opened this issue Jun 3, 2019 · 5 comments

Comments

Projects
None yet
4 participants
@wonxin
Copy link

commented Jun 3, 2019

1.5.0 urllib3版本冲突问题

elasticsearch 6.1.1 与 jms-storage 0.0.23 要求的 urllib3 版本冲突

使用版本

jumpserver 1.5.0

问题复现步骤
  1. 执行 pip install -r requirements/requirements.txt

    提示:
    elasticsearch 6.1.1 has requirement urllib3<1.23,>=1.21.1

    但requirements.txt 文件里要求 urllib3==1.25.2

  2. 将 requirements.txt 文件里 urllib3 换成 1.22,
    执行 pip install -r requirements/requirements.txt

    提示:
    jms-storage 0.0.23 has requirement urllib3==1.25.2

@vitaureatea

This comment has been minimized.

Copy link

commented Jun 9, 2019

我也遇到了这个问题。。。。。。。。。。。。。。。。。。。

@ibuler

This comment has been minimized.

Copy link
Member

commented Jun 13, 2019

升级一下elasticsearch到 7.0.2版本

@wonxin

This comment has been minimized.

Copy link
Author

commented Jun 13, 2019

升级一下elasticsearch到 7.0.2版本

@ibuler, 将 elasticsearh 从 6.1.1 替换为 7.0.2,执行依旧报错:

sed -i 's/elasticsearch==6.1.1/elasticsearch==7.0.2/' requirements/requirements.txt
pip3 install -r requirements/requirements.txt

提示:
ERROR: jms-storage 0.0.23 has requirement elasticsearch==6.1.1

@wonxin

This comment has been minimized.

Copy link
Author

commented Jun 13, 2019

目前情况:

jms-storage 0.0.23 要求:
elasticsearch==6.1.1
urllib3==1.25.2

但 elasticsearch==6.1.1 要求 urllib3<1.23,>=1.21.1, 与 urllib3==1.25.2 冲突

@Cuigeek

This comment has been minimized.

Copy link

commented Jun 14, 2019

我也会遇到同样问题 目前没有找到解决方案

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.