Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

【文件下载】- 通过sftp下载文件异常,文件损坏 #3063

Closed
supershrek opened this issue Aug 1, 2019 · 18 comments

Comments

@supershrek
Copy link

commented Aug 1, 2019

[简述你的问题]
文件下载方式有两种:
1、通过web系统进到文件管理界面,做上传/下载操作,上传和下载的文件没任何问题,能正常打开!!!但是因为web没那么稳定,而且不支持断点续传,传大文件没那么方便
2、通过sftp终端来传输,传输稳定,支持断点续传,但是发现上传文件无异常,能正常打开,下载文件,打开出现异常,提示文件损坏等,无论文件大小

使用版本

[请提供你使用的Jumpserver版本 1.x.x 注: 0.3.x不再提供支持]
最新版本,
Version 1.5.0-2

问题复现步骤
  1. [步骤1]
  2. [步骤2]
    文件下载方式有两种:
    1、通过web系统进到文件管理界面,做上传/下载操作,上传和下载的文件没任何问题,能正常打开!!!但是因为web没那么稳定,而且不支持断点续传,传大文件没那么方便
    2、通过sftp终端来传输,传输稳定,支持断点续传,但是发现上传文件无异常,能正常打开,下载文件,打开出现异常,提示文件损坏等,无论文件大小
具体表现[截图可能会更好些,最好能截全]
其他

[注:] 完成后请关闭 issue

@jym503558564

This comment has been minimized.

Copy link
Contributor

commented Aug 1, 2019

  • 关于版本号查看的问题:
    - 在页面右下角可查看
@supershrek

This comment has been minimized.

Copy link
Author

commented Aug 1, 2019

  • 关于版本号查看的问题:
    • 在页面右下角可查看

谢谢,看到了,版本是: Version 1.5.0-2

@ibuler

This comment has been minimized.

Copy link
Member

commented Aug 8, 2019

@LeeEirc

This comment has been minimized.

Copy link
Contributor

commented Aug 9, 2019

@supershrek 建议使用最新的1.5.2。

@supershrek

This comment has been minimized.

Copy link
Author

commented Aug 14, 2019

@supershrek 建议使用最新的1.5.2。

谢谢,我根据官网的升级指引升级到1.5.2之后,出现web终端不能使用的问题,跟踪了一下,发现是koko容器里面的koko进程的问题 直接返回400

@supershrek

This comment has been minimized.

Copy link
Author

commented Aug 14, 2019

@supershrek 建议使用最新的1.5.2。

能不能麻烦看下,比较着急

@LeeEirc

This comment has been minimized.

Copy link
Contributor

commented Aug 14, 2019

@supershrek

This comment has been minimized.

Copy link
Author

commented Aug 14, 2019

koko需要使用最新版本的luna。先检查一下各组件是否都正常。nginx配置是否正确。有无异常错误,最好能贴出截图和相关日志。 | | 李智 邮箱:xplzv@126.com | 签名由 网易邮箱大师 定制 在2019年08月14日 19:10,supershrek 写道: @supershrek 建议使用最新的1.5.2。 能不能麻烦看下,比较着急 — You are receiving this because you were mentioned. Reply to this email directly, view it on GitHub, or mute the thread.

根据你们提供的升级步骤,下载的是1.5.2的luna,其他功能都正常,就只有web 终端展示有问题了
image

卡住了一样,下载文件损坏的bug已经修复,window连接也比原来稳定和快了

我跟踪进去发现是koko容器里面访问就是400 反馈异常

@supershrek

This comment has been minimized.

Copy link
Author

commented Aug 14, 2019

koko需要使用最新版本的luna。先检查一下各组件是否都正常。nginx配置是否正确。有无异常错误,最好能贴出截图和相关日志。 | | 李智 邮箱:xplzv@126.com | 签名由 网易邮箱大师 定制 在2019年08月14日 19:10,supershrek 写道: @supershrek 建议使用最新的1.5.2。 能不能麻烦看下,比较着急 — You are receiving this because you were mentioned. Reply to this email directly, view it on GitHub, or mute the thread.

版本从1.5.0 升级到 1.5.2 之后会话管理里面的web终端异常,点击不能进入对应的服务器,直接通过ssh终端登录没问题

抓包发现错误为: Status Code: 400 Bad Request

即访问 5000端口的服务会出现这个问题

进到容器中直接连接 5000,直接反馈 400 Bad Request ,说明容器内的koko服务有问题

@LeeEirc

This comment has been minimized.

Copy link
Contributor

commented Aug 15, 2019

@supershrek 可能是你的nginx配置不对,你查看一下koko容器的日志?

@supershrek

This comment has been minimized.

Copy link
Author

commented Aug 15, 2019

@supershrek 可能是你的nginx配置不对,你查看一下koko容器的日志?

nginx的配置是按照你们说明配置的,而且我测试了下,其他业务都是正常的,资产都可以测试连通等。看可能是nginx哪里配置的问题?

请教一下,怎么查看koko容器的日志?

@supershrek

This comment has been minimized.

Copy link
Author

commented Aug 15, 2019

@supershrek 可能是你的nginx配置不对,你查看一下koko容器的日志?

2019-08-15 16:48:17 [ERRO] ERROR: websocket: the client is not using the websocket protocol: 'websocket' token not found in 'Upgrade' header
2019-08-15 16:48:17 [ERRO] ERROR: websocket: the client is not using the websocket protocol:

感觉是有点问题

@supershrek

This comment has been minimized.

Copy link
Author

commented Aug 15, 2019

@LeeEirc ,koko的log拿到了,麻烦看下要怎么解决

2019-08-15 16:48:17 [ERRO] ERROR: websocket: the client is not using the websocket protocol: 'websocket' token not found in 'Upgrade' header
2019-08-15 16:48:17 [ERRO] ERROR: websocket: the client is not using the websocket protocol:

@LeeEirc

This comment has been minimized.

Copy link
Contributor

commented Aug 16, 2019

@supershrek 如果koko已经是最新的话,那么你luna版本可能不是最新的

@supershrek

This comment has been minimized.

Copy link
Author

commented Aug 16, 2019

@supershrek 如果koko已经是最新的话,那么你luna版本可能不是最新的

比较了md5确定是最新的

@LeeEirc

This comment has been minimized.

Copy link
Contributor

commented Aug 16, 2019

@supershrek 加入koko群908100817交流一下。

@supershrek

This comment has been minimized.

Copy link
Author

commented Aug 16, 2019

@BaiJiangJie ,你好,感觉这个是1.5.2的luna的bug,我没有重新部署,直接从1.5.0升级到1.5.2的,就出现web终端无妨访问的问题

@supershrek

This comment has been minimized.

Copy link
Author

commented Aug 16, 2019

升级到1.5.2 后解决了下载文件的损坏问题

@supershrek supershrek closed this Aug 16, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.