No description, website, or topics provided.
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
examples
scripts
src
test
typings
.gitignore
.travis.yml
CONTRIBUTING.md
LICENSE
README.md
package.json

README.md

Jupyter JS UI

JavaScript UI Components for Jupyter.

API Docs

Package Install

Prerequisites

npm install --save jupyter-js-ui
conda install notebook  # notebook 4.2+ required

Source Build

Prerequisites

git clone https://github.com/jupyter/jupyter-js-ui.git
cd jupyter-js-ui
npm install
npm run build
conda install notebook  # notebook 4.2+ required

Rebuild

npm run clean
npm run build

Run Tests

Follow the source build instructions first.

npm test

Build Examples

Follow the source build instructions first. Requires a Python install with the Jupyter notebook.

npm run build:examples

Change to appropriate examples directory and run python main.py.

Build Docs

Follow the source build instructions first.

npm run docs

Navigate to docs/index.html.

Supported Runtimes

The runtime versions which are currently known to work are listed below. Earlier versions may also work, but come with no guarantees.

  • IE 11+
  • Firefox 32+
  • Chrome 38+

Note: "requirejs" must be included in a global context (usually as a <script> tag) for Comm targets.

Bundle for the Browser

Follow the package install instructions first.

Any bundler that understands how to require() files with .js and .css extensions can be used with this package.

Usage Examples

Note: This module is fully compatible with Node/Babel/ES6/ES5. Simply omit the type declarations when using a language other than TypeScript.