New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Some questions in normal installation #45

Closed
00Kai0 opened this Issue Jan 29, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@00Kai0
Copy link
Contributor

00Kai0 commented Jan 29, 2019

@leportella
When I install this module (not develop install), I find some questions.
1.
After pip install ., I use from nativeauthenticator import NativeAuthenticator.It shows some error

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/home/kai/work/embark3_env/venv/lib/python3.5/site-packages/nativeauthenticator/__init__.py", line 4, in <module>
    from nativeauthenticator.nativeauthenticator import NativeAuthenticator
  File "/home/kai/work/embark3_env/venv/lib/python3.5/site-packages/nativeauthenticator/nativeauthenticator.py", line 1, in <module>
    import bcrypt
ImportError: No module named 'bcrypt'

I saw you put bcrypt into dev-requirements.txt, I think you should put it into setup.py's install_requires. (It just my suggestions).
2.
It's about f-string.

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/home/kai/work/embark3_env/venv/lib/python3.5/site-packages/nativeauthenticator/__init__.py", line 4, in <module>
    from nativeauthenticator.nativeauthenticator import NativeAuthenticator
  File "/home/kai/work/embark3_env/venv/lib/python3.5/site-packages/nativeauthenticator/nativeauthenticator.py", line 10, in <module>
    from .handlers import (AuthorizationHandler, ChangeAuthorizationHandler,
  File "/home/kai/work/embark3_env/venv/lib/python3.5/site-packages/nativeauthenticator/handlers.py", line 53
    f"at least {pw_len} characters, doesn't have "
    ^
SyntaxError: invalid syntax

This is a new string format in python3.6 (I usually use python3.5). If you just want to support python>=3.6, you need set python_requires=">=3.6" in setup.py. The other way is changing the format style to support 3.4 or 3.5.
This is all my questions. Thank you.
If you wanne help, I can have a try.

@leportella

This comment has been minimized.

Copy link
Collaborator

leportella commented Feb 5, 2019

@00Kai0 thanks for your feedback! I'll remove the f-string to assure backward compability and will add bcrypt as a dependency as well!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment