Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We鈥檒l occasionally send you account related emails.

Already on GitHub? Sign in to your account

jupyter labextension install should be less noisy #5986

Closed
yuvipanda opened this issue Feb 14, 2019 · 7 comments
Closed

jupyter labextension install should be less noisy #5986

yuvipanda opened this issue Feb 14, 2019 · 7 comments

Comments

@yuvipanda
Copy link
Contributor

@yuvipanda yuvipanda commented Feb 14, 2019

Currently, running jupyter labextension install <something> provides a ton of output, even though nothing is wrong.

> /usr/bin/npm pack @jupyterlab/hub-extension
npm notice 
npm notice 馃摝  @jupyterlab/hub-extension@0.12.0
npm notice === Tarball Contents === 
npm notice 908B  package.json  
npm notice 1.5kB LICENSE       
npm notice 1.5kB README.md     
npm notice 351B  lib/index.d.ts
npm notice 2.6kB lib/index.js  
npm notice === Tarball Details === 
npm notice name:          @jupyterlab/hub-extension               
npm notice version:       0.12.0                                  
npm notice filename:      jupyterlab-hub-extension-0.12.0.tgz     
npm notice package size:  3.0 kB                                  
npm notice unpacked size: 6.9 kB                                  
npm notice shasum:        2928622d6b5dfd67b859948f08bf0cf8c55f5717
npm notice integrity:     sha512-3iR402o7GNcyn[...]jCq3H+ROnFhkg==
npm notice total files:   5                                       
npm notice 
jupyterlab-hub-extension-0.12.0.tgz
Incompatible extension:

"@jupyterlab/hub-extension@0.12.0" is not compatible with the current JupyterLab
Conflicting Dependencies:
JupyterLab Extension Package

=0.18.4 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/application
=0.18.4 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/apputils

Found compatible version: 0.11.0

/usr/bin/npm pack @jupyterlab/hub-extension@0.11.0
npm notice
npm notice 馃摝 @jupyterlab/hub-extension@0.11.0
npm notice === Tarball Contents ===
npm notice 908B package.json
npm notice 1.5kB LICENSE
npm notice 1.5kB README.md
npm notice 351B lib/index.d.ts
npm notice 2.6kB lib/index.js
npm notice === Tarball Details ===
npm notice name: @jupyterlab/hub-extension
npm notice version: 0.11.0
npm notice filename: jupyterlab-hub-extension-0.11.0.tgz
npm notice package size: 3.0 kB
npm notice unpacked size: 6.9 kB
npm notice shasum: da7c5045a57d032937d05b6de6eff3a790a75ddb
npm notice integrity: sha512-DWd9E3T+CRo0p[...]qrB37eoHGHWgQ==
npm notice total files: 5
npm notice
jupyterlab-hub-extension-0.11.0.tgz
/usr/bin/npm pack @jupyter-widgets/jupyterlab-manager
npm notice
npm notice 馃摝 @jupyter-widgets/jupyterlab-manager@0.39.1
npm notice === Tarball Contents ===
npm notice 2.0kB package.json
npm notice 2.0kB README.md
npm notice 274B lib/index.d.ts
npm notice 946B lib/index.js
npm notice 2.5kB lib/manager.d.ts
npm notice 6.3kB lib/manager.js
npm notice 1.9kB lib/output.d.ts
npm notice 6.0kB lib/output.js
npm notice 1.1kB lib/plugin.d.ts
npm notice 3.6kB lib/plugin.js
npm notice 829B lib/renderer.d.ts
npm notice 3.0kB lib/renderer.js
npm notice 216B lib/semvercache.d.ts
npm notice 972B lib/semvercache.js
npm notice === Tarball Details ===
npm notice name: @jupyter-widgets/jupyterlab-manager
npm notice version: 0.39.1
npm notice filename: jupyter-widgets-jupyterlab-manager-0.39.1.tgz
npm notice package size: 7.8 kB
npm notice unpacked size: 31.5 kB
npm notice shasum: 696ac955ae59755e607edd62945b628a6f36f366
npm notice integrity: sha512-aroyIWnKKRcHw[...]Q3VuOgq76z5vQ==
npm notice total files: 14
npm notice
jupyter-widgets-jupyterlab-manager-0.39.1.tgz
Incompatible extension:

"@jupyter-widgets/jupyterlab-manager@0.39.1" is not compatible with the current JupyterLab
Conflicting Dependencies:
JupyterLab Extension Package

=0.18.4 <0.19.0 >=1.0.0-alpha.3 <2.0.0@jupyterlab/application
=0.18.4 <0.19.0 >=1.0.0-alpha.4 <2.0.0@jupyterlab/notebook
=0.18.4 <0.19.0 >=1.0.0-alpha.3 <2.0.0@jupyterlab/rendermime

Found compatible version: 0.37.4

/usr/bin/npm pack @jupyter-widgets/jupyterlab-manager@0.37.4
npm notice
npm notice 馃摝 @jupyter-widgets/jupyterlab-manager@0.37.4
npm notice === Tarball Contents ===
npm notice 2.0kB package.json
npm notice 1.5kB LICENSE
npm notice 1.9kB README.md
npm notice 131B lib/index.d.ts
npm notice 410B lib/index.js
npm notice 2.5kB lib/manager.d.ts
npm notice 6.2kB lib/manager.js
npm notice 1.9kB lib/output.d.ts
npm notice 6.0kB lib/output.js
npm notice 1.1kB lib/plugin.d.ts
npm notice 3.6kB lib/plugin.js
npm notice 829B lib/renderer.d.ts
npm notice 3.0kB lib/renderer.js
npm notice 216B lib/semvercache.d.ts
npm notice 972B lib/semvercache.js
npm notice === Tarball Details ===
npm notice name: @jupyter-widgets/jupyterlab-manager
npm notice version: 0.37.4
npm notice filename: jupyter-widgets-jupyterlab-manager-0.37.4.tgz
npm notice package size: 8.5 kB
npm notice unpacked size: 32.2 kB
npm notice shasum: c21b51fc17da7cce037a94511301c32bd3d4cd85
npm notice integrity: sha512-JMEbRK8n10A/6[...]svM+OhGvMxkVA==
npm notice total files: 15
npm notice
jupyter-widgets-jupyterlab-manager-0.37.4.tgz
/usr/bin/npm pack jupyter-matplotlib
npm notice
npm notice 馃摝 jupyter-matplotlib@0.3.0
npm notice === Tarball Contents ===
npm notice 889B package.json
npm notice 161B README.md
npm notice 2.5kB webpack.config.js
npm notice 847.3kB dist/index.js
npm notice 1.1MB dist/index.js.map
npm notice 455B src/embed.js
npm notice 182B src/index.js
npm notice 434B src/lab_extension.js
npm notice 5.6kB src/mpl_widget.js
npm notice 17.1kB src/mpl.js
npm notice 309B src/nb_extension.js
npm notice 520B src/nb_index.js
npm notice === Tarball Details ===
npm notice name: jupyter-matplotlib
npm notice version: 0.3.0
npm notice filename: jupyter-matplotlib-0.3.0.tgz
npm notice package size: 397.8 kB
npm notice unpacked size: 1.9 MB
npm notice shasum: 35e71924ebecaf6926eaf52e92c7e206aecbae7f
npm notice integrity: sha512-uJpU8dCeoRyqy[...]yiygnTrTTqNqg==
npm notice total files: 12
npm notice
jupyter-matplotlib-0.3.0.tgz
/usr/bin/npm pack @jupyterlab/plotly-extension
npm notice
npm notice 馃摝 @jupyterlab/plotly-extension@0.18.2
npm notice === Tarball Contents ===
npm notice 1.2kB package.json
npm notice 1.5kB LICENSE
npm notice 2.4kB README.md
npm notice 1.3kB lib/index.d.ts
npm notice 3.7kB lib/index.js
npm notice 546B style/index.css
npm notice 1.7kB style/plotly.svg
npm notice === Tarball Details ===
npm notice name: @jupyterlab/plotly-extension
npm notice version: 0.18.2
npm notice filename: jupyterlab-plotly-extension-0.18.2.tgz
npm notice package size: 4.7 kB
npm notice unpacked size: 12.4 kB
npm notice shasum: 146b2a2eb83e6b9ee2b1cb62fe4913dd3ebb2674
npm notice integrity: sha512-LadmZ3YQWaE7d[...]dUaEDoBlxtnbQ==
npm notice total files: 7
npm notice
jupyterlab-plotly-extension-0.18.2.tgz
/usr/bin/npm pack @jupyterlab/geojson-extension
npm notice
npm notice 馃摝 @jupyterlab/geojson-extension@0.18.1
npm notice === Tarball Contents ===
npm notice 1.2kB package.json
npm notice 1.5kB LICENSE
npm notice 2.6kB README.md
npm notice 1.5kB lib/index.d.ts
npm notice 5.6kB lib/index.js
npm notice 1.0kB style/geojson.svg
npm notice 549B style/index.css
npm notice === Tarball Details ===
npm notice name: @jupyterlab/geojson-extension
npm notice version: 0.18.1
npm notice filename: jupyterlab-geojson-extension-0.18.1.tgz
npm notice package size: 5.3 kB
npm notice unpacked size: 14.0 kB
npm notice shasum: 5605ed7bdbf567c065c9b58eec5cfbf74c147cb6
npm notice integrity: sha512-/rpbzsbAvAUCL[...]D6bjnL03H4FVg==
npm notice total files: 7
npm notice
jupyterlab-geojson-extension-0.18.1.tgz
/usr/bin/npm pack @jupyterlab/git
npm notice
npm notice 馃摝 @jupyterlab/git@0.5.0
npm notice === Tarball Contents ===
npm notice 2.1kB package.json
npm notice 1.5kB LICENSE
npm notice 2.6kB README.md
npm notice 1.2kB lib/components/BranchHeader.d.ts
npm notice 8.3kB lib/components/BranchHeader.js
npm notice 741B lib/components/CommitBox.d.ts
npm notice 2.4kB lib/components/CommitBox.js
npm notice 1.6kB lib/components/FileItem.d.ts
npm notice 7.8kB lib/components/FileItem.js
npm notice 3.8kB lib/components/FileList.d.ts
npm notice 21.0kB lib/components/FileList.js
npm notice 1.1kB lib/components/GitPanel.d.ts
npm notice 10.1kB lib/components/GitPanel.js
npm notice 1.6kB lib/components/GitStage.d.ts
npm notice 4.7kB lib/components/GitStage.js
npm notice 2.9kB lib/components/GitWidget.d.ts
npm notice 3.9kB lib/components/GitWidget.js
npm notice 649B lib/components/HistorySideBar.d.ts
npm notice 878B lib/components/HistorySideBar.js
npm notice 546B lib/components/NewBranchBox.d.ts
npm notice 1.7kB lib/components/NewBranchBox.js
npm notice 806B lib/components/PastCommitNode.d.ts
npm notice 3.8kB lib/components/PastCommitNode.js
npm notice 574B lib/components/PastCommits.d.ts
npm notice 950B lib/components/PastCommits.js
npm notice 865B lib/components/PathHeader.d.ts
npm notice 2.8kB lib/components/PathHeader.js
npm notice 570B lib/components/ResetDeleteSingleCommit.d.ts
npm notice 2.9kB lib/components/ResetDeleteSingleCommit.js
npm notice 1.1kB lib/components/SinglePastCommitInfo.d.ts
npm notice 7.3kB lib/components/SinglePastCommitInfo.js
npm notice 1.3kB lib/componentsStyle/BranchHeaderStyle.d.ts
npm notice 5.9kB lib/componentsStyle/BranchHeaderStyle.js
npm notice 923B lib/componentsStyle/FileItemStyle.d.ts
npm notice 2.9kB lib/componentsStyle/FileItemStyle.js
npm notice 1.6kB lib/componentsStyle/FileListStyle.d.ts
npm notice 3.8kB lib/componentsStyle/FileListStyle.js
npm notice 148B lib/componentsStyle/GitPanelStyle.d.ts
npm notice 505B lib/componentsStyle/GitPanelStyle.js
npm notice 558B lib/componentsStyle/GitStageStyle.d.ts
npm notice 2.8kB lib/componentsStyle/GitStageStyle.js
npm notice 87B lib/componentsStyle/GitWidgetStyle.d.ts
npm notice 451B lib/componentsStyle/GitWidgetStyle.js
npm notice 50B lib/componentsStyle/HistorySideBarStyle.d.ts
npm notice 244B lib/componentsStyle/HistorySideBarStyle.js
npm notice 297B lib/componentsStyle/NewBranchBoxStyle.d.ts
npm notice 1.4kB lib/componentsStyle/NewBranchBoxStyle.js
npm notice 536B lib/componentsStyle/PastCommitNodeStyle.d.ts
npm notice 1.3kB lib/componentsStyle/PastCommitNodeStyle.js
npm notice 56B lib/componentsStyle/PastCommitsStyle.d.ts
npm notice 203B lib/componentsStyle/PastCommitsStyle.js
npm notice 267B lib/componentsStyle/PathHeaderStyle.d.ts
npm notice 3.2kB lib/componentsStyle/PathHeaderStyle.js
npm notice 1.1kB lib/componentsStyle/SinglePastCommitInfoStyle.d.ts
npm notice 4.1kB lib/componentsStyle/SinglePastCommitInfoStyle.js
npm notice 5.8kB lib/git.d.ts
npm notice 14.8kB lib/git.js
npm notice 1.8kB lib/gitClone.d.ts
npm notice 6.3kB lib/gitClone.js
npm notice 594B lib/gitMenuCommands.d.ts
npm notice 5.7kB lib/gitMenuCommands.js
npm notice 1.4kB lib/index.d.ts
npm notice 3.6kB lib/index.js
npm notice 401B style/images/arrow-down-white.svg
npm notice 386B style/images/arrow-down.svg
npm notice 3.9kB style/images/author.svg
npm notice 4.7kB style/images/branch.svg
npm notice 601B style/images/caretdownwhite.svg
npm notice 621B style/images/caretrightwhite.svg
npm notice 215B style/images/checkmark-icon.svg
npm notice 266B style/images/clear-white.svg
npm notice 3.9kB style/images/deletion-color.svg
npm notice 3.9kB style/images/deletion-white.svg
npm notice 304B style/images/deletions-made-icon-white.svg
npm notice 289B style/images/deletions-made-icon.svg
npm notice 4.4kB style/images/directory-white.svg
npm notice 4.4kB style/images/directory.svg
npm notice 242B style/images/discard-selected.svg
npm notice 242B style/images/discard.svg
npm notice 2.7kB style/images/edit-circle-active.svg
npm notice 2.7kB style/images/edit-circle-selected-active.svg
npm notice 2.7kB style/images/edit-circle-selected.svg
npm notice 2.7kB style/images/edit-circle.svg
npm notice 841B style/images/fade-left.svg
npm notice 836B style/images/fade-right.svg
npm notice 1.3kB style/images/git-clone-icon-disabled.svg
npm notice 1.3kB style/images/git-clone-icon.svg
npm notice 2.8kB style/images/git-icon.svg
npm notice 654B style/images/git-pull-white.svg
npm notice 656B style/images/git-pull.svg
npm notice 647B style/images/git-push-white.svg
npm notice 649B style/images/git-push.svg
npm notice 767B style/images/head-circle-active.svg
npm notice 767B style/images/head-circle-selected-active.svg
npm notice 766B style/images/head-circle-selected.svg
npm notice 766B style/images/head-circle.svg
npm notice 469B style/images/home.svg
npm notice 315B style/images/icon-branch-tracking.svg
npm notice 323B style/images/insertions-made-icon-white.svg
npm notice 308B style/images/insertions-made-icon.svg
npm notice 1.8kB style/images/left-arrow.svg
npm notice 173B style/images/move-file-down-hover.svg
npm notice 175B style/images/move-file-down.svg
npm notice 170B style/images/move-file-up-hover.svg
npm notice 169B style/images/move-file-up.svg
npm notice 681B style/images/normal-circle-active.svg
npm notice 760B style/images/normal-circle-selected-active.svg
npm notice 674B style/images/normal-circle-selected.svg
npm notice 595B style/images/normal-circle.svg
npm notice 481B style/images/path-arrow-right.svg
npm notice 200B style/images/plus-white.svg
npm notice 185B style/images/plus.svg
npm notice 4.0kB style/images/refresh-hover.svg
npm notice 4.0kB style/images/refresh.svg
npm notice 3.9kB style/images/reset-white.svg
npm notice 3.9kB style/images/reset.svg
npm notice 389B style/images/rewind-white.svg
npm notice 374B style/images/rewind.svg
npm notice 1.8kB style/images/right-arrow.svg
npm notice 8.6kB style/images/track.svg
npm notice 4.4kB style/images/triangle-down-white.svg
npm notice 3.8kB style/images/triangle-down.svg
npm notice 4.4kB style/images/triangle-right-white.svg
npm notice 3.8kB style/images/triangle-right.svg
npm notice 2.5kB style/variables.css
npm notice === Tarball Details ===
npm notice name: @jupyterlab/git
npm notice version: 0.5.0
npm notice filename: jupyterlab-git-0.5.0.tgz
npm notice package size: 43.5 kB
npm notice unpacked size: 281.9 kB
npm notice shasum: 0bcc3a59e316df106c7c1c2a957c3aece305f0e3
npm notice integrity: sha512-pZBw7GWOWkr6H[...]2OxhgBQufq80Q==
npm notice total files: 125
npm notice
jupyterlab-git-0.5.0.tgz
Incompatible extension:

"@jupyterlab/git@0.5.0" is not compatible with the current JupyterLab
Conflicting Dependencies:
JupyterLab Extension Package

=0.18.4 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/application
=0.18.4 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/apputils
=0.18.4 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/console
=0.18.6 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/filebrowser
=0.18.4 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/terminal

Found compatible version: 0.2.2

/usr/bin/npm pack @jupyterlab/git@0.2.2
npm notice
npm notice 馃摝 @jupyterlab/git@0.2.2
npm notice === Tarball Contents ===
npm notice 1.5kB package.json
npm notice 1.5kB LICENSE
npm notice 1.5kB README.md
npm notice 1.1kB lib/components_style/BranchHeaderStyle.d.ts
npm notice 5.0kB lib/components_style/BranchHeaderStyle.js
npm notice 923B lib/components_style/FileItemStyle.d.ts
npm notice 2.9kB lib/components_style/FileItemStyle.js
npm notice 1.6kB lib/components_style/FileListStyle.d.ts
npm notice 3.8kB lib/components_style/FileListStyle.js
npm notice 250B lib/components_style/GitPanelStyle.d.ts
npm notice 805B lib/components_style/GitPanelStyle.js
npm notice 558B lib/components_style/GitStageStyle.d.ts
npm notice 2.8kB lib/components_style/GitStageStyle.js
npm notice 45B lib/components_style/GitWidgetStyle.d.ts
npm notice 363B lib/components_style/GitWidgetStyle.js
npm notice 108B lib/components_style/HistorySideBarStyle.d.ts
npm notice 815B lib/components_style/HistorySideBarStyle.js
npm notice 297B lib/components_style/NewBranchBoxStyle.d.ts
npm notice 1.2kB lib/components_style/NewBranchBoxStyle.js
npm notice 445B lib/components_style/PastCommitNodeStyle.d.ts
npm notice 1.3kB lib/components_style/PastCommitNodeStyle.js
npm notice 56B lib/components_style/PastCommitsStyle.d.ts
npm notice 203B lib/components_style/PastCommitsStyle.js
npm notice 317B lib/components_style/PathHeaderStyle.d.ts
npm notice 2.0kB lib/components_style/PathHeaderStyle.js
npm notice 1.3kB lib/components_style/SinglePastCommitInfoStyle.d.ts
npm notice 4.8kB lib/components_style/SinglePastCommitInfoStyle.js
npm notice 1.1kB lib/components/BranchHeader.d.ts
npm notice 6.4kB lib/components/BranchHeader.js
npm notice 741B lib/components/CommitBox.d.ts
npm notice 2.4kB lib/components/CommitBox.js
npm notice 1.4kB lib/components/FileItem.d.ts
npm notice 7.9kB lib/components/FileItem.js
npm notice 3.8kB lib/components/FileList.d.ts
npm notice 20.4kB lib/components/FileList.js
npm notice 1.5kB lib/components/GitPanel.d.ts
npm notice 11.5kB lib/components/GitPanel.js
npm notice 1.4kB lib/components/GitStage.d.ts
npm notice 4.8kB lib/components/GitStage.js
npm notice 2.9kB lib/components/GitWidget.d.ts
npm notice 3.9kB lib/components/GitWidget.js
npm notice 694B lib/components/HistorySideBar.d.ts
npm notice 1.8kB lib/components/HistorySideBar.js
npm notice 546B lib/components/NewBranchBox.d.ts
npm notice 1.7kB lib/components/NewBranchBox.js
npm notice 637B lib/components/PastCommitNode.d.ts
npm notice 2.8kB lib/components/PastCommitNode.js
npm notice 859B lib/components/PastCommits.d.ts
npm notice 1.6kB lib/components/PastCommits.js
npm notice 395B lib/components/PathHeader.d.ts
npm notice 1.3kB lib/components/PathHeader.js
npm notice 570B lib/components/ResetDeleteSingleCommit.d.ts
npm notice 2.9kB lib/components/ResetDeleteSingleCommit.js
npm notice 951B lib/components/SinglePastCommitInfo.d.ts
npm notice 5.8kB lib/components/SinglePastCommitInfo.js
npm notice 1.1kB lib/componentsStyle/BranchHeaderStyle.d.ts
npm notice 5.0kB lib/componentsStyle/BranchHeaderStyle.js
npm notice 923B lib/componentsStyle/FileItemStyle.d.ts
npm notice 2.9kB lib/componentsStyle/FileItemStyle.js
npm notice 1.6kB lib/componentsStyle/FileListStyle.d.ts
npm notice 3.8kB lib/componentsStyle/FileListStyle.js
npm notice 250B lib/componentsStyle/GitPanelStyle.d.ts
npm notice 805B lib/componentsStyle/GitPanelStyle.js
npm notice 558B lib/componentsStyle/GitStageStyle.d.ts
npm notice 2.8kB lib/componentsStyle/GitStageStyle.js
npm notice 87B lib/componentsStyle/GitWidgetStyle.d.ts
npm notice 451B lib/componentsStyle/GitWidgetStyle.js
npm notice 108B lib/componentsStyle/HistorySideBarStyle.d.ts
npm notice 815B lib/componentsStyle/HistorySideBarStyle.js
npm notice 297B lib/componentsStyle/NewBranchBoxStyle.d.ts
npm notice 1.2kB lib/componentsStyle/NewBranchBoxStyle.js
npm notice 445B lib/componentsStyle/PastCommitNodeStyle.d.ts
npm notice 1.3kB lib/componentsStyle/PastCommitNodeStyle.js
npm notice 56B lib/componentsStyle/PastCommitsStyle.d.ts
npm notice 203B lib/componentsStyle/PastCommitsStyle.js
npm notice 317B lib/componentsStyle/PathHeaderStyle.d.ts
npm notice 2.0kB lib/componentsStyle/PathHeaderStyle.js
npm notice 1.3kB lib/componentsStyle/SinglePastCommitInfoStyle.d.ts
npm notice 4.8kB lib/componentsStyle/SinglePastCommitInfoStyle.js
npm notice 594B lib/git_mainmenu_command.d.ts
npm notice 5.6kB lib/git_mainmenu_command.js
npm notice 5.1kB lib/git.d.ts
npm notice 12.9kB lib/git.js
npm notice 594B lib/gitMenuCommands.d.ts
npm notice 5.6kB lib/gitMenuCommands.js
npm notice 1.2kB lib/index.d.ts
npm notice 3.4kB lib/index.js
npm notice 401B style/images/arrow-down-white.svg
npm notice 386B style/images/arrow-down.svg
npm notice 3.9kB style/images/author.svg
npm notice 4.7kB style/images/branch.svg
npm notice 601B style/images/caretdownwhite.svg
npm notice 621B style/images/caretrightwhite.svg
npm notice 215B style/images/checkmark-icon.svg
npm notice 266B style/images/clear-white.svg
npm notice 3.9kB style/images/deletion-color.svg
npm notice 3.9kB style/images/deletion-white.svg
npm notice 304B style/images/deletions-made-icon-white.svg
npm notice 289B style/images/deletions-made-icon.svg
npm notice 4.4kB style/images/directory-white.svg
npm notice 4.4kB style/images/directory.svg
npm notice 242B style/images/discard-selected.svg
npm notice 242B style/images/discard.svg
npm notice 2.7kB style/images/edit-circle-active.svg
npm notice 2.7kB style/images/edit-circle-selected-active.svg
npm notice 2.7kB style/images/edit-circle-selected.svg
npm notice 2.7kB style/images/edit-circle.svg
npm notice 841B style/images/fade-left.svg
npm notice 836B style/images/fade-right.svg
npm notice 2.8kB style/images/git-icon.svg
npm notice 767B style/images/head-circle-active.svg
npm notice 767B style/images/head-circle-selected-active.svg
npm notice 766B style/images/head-circle-selected.svg
npm notice 766B style/images/head-circle.svg
npm notice 469B style/images/home.svg
npm notice 323B style/images/insertions-made-icon-white.svg
npm notice 308B style/images/insertions-made-icon.svg
npm notice 1.8kB style/images/left-arrow.svg
npm notice 173B style/images/move-file-down-hover.svg
npm notice 175B style/images/move-file-down.svg
npm notice 170B style/images/move-file-up-hover.svg
npm notice 169B style/images/move-file-up.svg
npm notice 681B style/images/normal-circle-active.svg
npm notice 760B style/images/normal-circle-selected-active.svg
npm notice 674B style/images/normal-circle-selected.svg
npm notice 595B style/images/normal-circle.svg
npm notice 481B style/images/path-arrow-right.svg
npm notice 200B style/images/plus-white.svg
npm notice 185B style/images/plus.svg
npm notice 4.0kB style/images/refresh-hover.svg
npm notice 4.0kB style/images/refresh.svg
npm notice 3.9kB style/images/reset-white.svg
npm notice 3.9kB style/images/reset.svg
npm notice 389B style/images/rewind-white.svg
npm notice 374B style/images/rewind.svg
npm notice 1.8kB style/images/right-arrow.svg
npm notice 8.6kB style/images/track.svg
npm notice 4.4kB style/images/triangle-down-white.svg
npm notice 3.8kB style/images/triangle-down.svg
npm notice 4.4kB style/images/triangle-right-white.svg
npm notice 3.8kB style/images/triangle-right.svg
npm notice 2.0kB style/variables.css
npm notice === Tarball Details ===
npm notice name: @jupyterlab/git
npm notice version: 0.2.2
npm notice filename: jupyterlab-git-0.2.2.tgz
npm notice package size: 43.0 kB
npm notice unpacked size: 297.5 kB
npm notice shasum: 42c4ddbb16083807efdd24c5606c88a06d71f424
npm notice integrity: sha512-mSDVxHoOES12B[...]mMGwn91mwpSWg==
npm notice total files: 142
npm notice
jupyterlab-git-0.2.2.tgz
/usr/bin/npm pack @jupyterlab/latex
npm notice
npm notice 馃摝 @jupyterlab/latex@0.6.1
npm notice === Tarball Contents ===
npm notice 2.2kB package.json
npm notice 1.5kB LICENSE
npm notice 2.4kB README.md
npm notice 739B lib/error.d.ts
npm notice 1.4kB lib/error.js
npm notice 633B lib/index.d.ts
npm notice 19.0kB lib/index.js
npm notice 362B lib/pagenumber.d.ts
npm notice 3.8kB lib/pagenumber.js
npm notice 3.9kB lib/pdf.d.ts
npm notice 15.1kB lib/pdf.js
npm notice 401B schema/plugin.json
npm notice 600B style/fit_dark.svg
npm notice 600B style/fit_light.svg
npm notice 2.5kB style/index.css
npm notice 213B style/next_dark.svg
npm notice 213B style/next_light.svg
npm notice 210B style/previous_dark.svg
npm notice 210B style/previous_light.svg
npm notice 450B style/zoom_in_dark.svg
npm notice 450B style/zoom_in_light.svg
npm notice 411B style/zoom_out_dark.svg
npm notice 411B style/zoom_out_light.svg
npm notice === Tarball Details ===
npm notice name: @jupyterlab/latex
npm notice version: 0.6.1
npm notice filename: jupyterlab-latex-0.6.1.tgz
npm notice package size: 14.7 kB
npm notice unpacked size: 57.6 kB
npm notice shasum: cd05d10b794f5a81f31d42477d61cb4e7b118327
npm notice integrity: sha512-4f5hRvvdQQNej[...]ujSx520A7E7PA==
npm notice total files: 23
npm notice
jupyterlab-latex-0.6.1.tgz
Incompatible extension:

"@jupyterlab/latex@0.6.1" is not compatible with the current JupyterLab
Conflicting Dependencies:
JupyterLab Extension Package

=0.18.4 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/application
=0.18.4 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/apputils
=0.18.4 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/docmanager
=0.18.4 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/fileeditor

Found compatible version: 0.5.0

/usr/bin/npm pack @jupyterlab/latex@0.5.0
npm notice
npm notice 馃摝 @jupyterlab/latex@0.5.0
npm notice === Tarball Contents ===
npm notice 2.2kB package.json
npm notice 1.5kB LICENSE
npm notice 2.4kB README.md
npm notice 739B lib/error.d.ts
npm notice 1.4kB lib/error.js
npm notice 633B lib/index.d.ts
npm notice 18.9kB lib/index.js
npm notice 3.9kB lib/pdf.d.ts
npm notice 13.9kB lib/pdf.js
npm notice 401B schema/plugin.json
npm notice 600B style/fit_dark.svg
npm notice 600B style/fit_light.svg
npm notice 2.0kB style/index.css
npm notice 213B style/next_dark.svg
npm notice 213B style/next_light.svg
npm notice 210B style/previous_dark.svg
npm notice 210B style/previous_light.svg
npm notice 450B style/zoom_in_dark.svg
npm notice 450B style/zoom_in_light.svg
npm notice 411B style/zoom_out_dark.svg
npm notice 411B style/zoom_out_light.svg
npm notice === Tarball Details ===
npm notice name: @jupyterlab/latex
npm notice version: 0.5.0
npm notice filename: jupyterlab-latex-0.5.0.tgz
npm notice package size: 13.4 kB
npm notice unpacked size: 51.7 kB
npm notice shasum: 276ed56600ea6217c9ebd4a34a6b03aa0ad3a38a
npm notice integrity: sha512-+HI/ctOL6c9jI[...]hk5dIY6ElfIoA==
npm notice total files: 21
npm notice
jupyterlab-latex-0.5.0.tgz
/usr/bin/npm pack @jupyterlab/github
npm notice
npm notice 馃摝 @jupyterlab/github@0.10.0
npm notice === Tarball Contents ===
npm notice 2.2kB package.json
npm notice 1.5kB LICENSE
npm notice 6.3kB README.md
npm notice 1.6kB lib/browser.d.ts
npm notice 13.6kB lib/browser.js
npm notice 6.4kB lib/contents.d.ts
npm notice 23.0kB lib/contents.js
npm notice 4.8kB lib/github.d.ts
npm notice 3.1kB lib/github.js
npm notice 241B lib/index.d.ts
npm notice 5.3kB lib/index.js
npm notice 679B schema/drive.json
npm notice 2.4kB style/binder.svg
npm notice 2.3kB style/index.css
npm notice 35.4kB style/octocat_error.png
npm notice 2.1kB style/octocat-dark.svg
npm notice 2.1kB style/octocat-light.svg
npm notice === Tarball Details ===
npm notice name: @jupyterlab/github
npm notice version: 0.10.0
npm notice filename: jupyterlab-github-0.10.0.tgz
npm notice package size: 54.3 kB
npm notice unpacked size: 113.1 kB
npm notice shasum: 478b41611fac0990157a17347b7ee6efc403e7b9
npm notice integrity: sha512-1ZvCTEgU3fMCC[...]6o1jmZKadyfhw==
npm notice total files: 17
npm notice
jupyterlab-github-0.10.0.tgz
Incompatible extension:

"@jupyterlab/github@0.10.0" is not compatible with the current JupyterLab
Conflicting Dependencies:
JupyterLab Extension Package

=0.18.4 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/application
=0.18.4 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/apputils
=0.18.4 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/docmanager
=0.18.6 <0.19.0 >=0.19.1 <0.20.0 @jupyterlab/filebrowser

Found compatible version: 0.9.0

/usr/bin/npm pack @jupyterlab/github@0.9.0
npm notice
npm notice 馃摝 @jupyterlab/github@0.9.0
npm notice === Tarball Contents ===
npm notice 2.2kB package.json
npm notice 1.5kB LICENSE
npm notice 6.3kB README.md
npm notice 1.9kB lib/browser.d.ts
npm notice 14.0kB lib/browser.js
npm notice 6.0kB lib/contents.d.ts
npm notice 21.2kB lib/contents.js
npm notice 4.8kB lib/github.d.ts
npm notice 3.6kB lib/github.js
npm notice 241B lib/index.d.ts
npm notice 2.9kB lib/index.js
npm notice 451B schema/drive.json
npm notice 2.4kB style/binder.svg
npm notice 2.3kB style/index.css
npm notice 35.4kB style/octocat_error.png
npm notice 2.1kB style/octocat-dark.svg
npm notice 2.1kB style/octocat-light.svg
npm notice === Tarball Details ===
npm notice name: @jupyterlab/github
npm notice version: 0.9.0
npm notice filename: jupyterlab-github-0.9.0.tgz
npm notice package size: 53.4 kB
npm notice unpacked size: 109.4 kB
npm notice shasum: 8c29ee9828d3a8193e59cec3667510dc8d124e36
npm notice integrity: sha512-Cylk+/hIpCuYn[...]fBvHWZMRSRTdw==
npm notice total files: 17
npm notice
jupyterlab-github-0.9.0.tgz
node /srv/conda/lib/python3.6/site-packages/jupyterlab/staging/yarn.js install
yarn install v1.9.4
info No lockfile found.
[1/4] Resolving packages...
(node:281) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.
warning @jupyterlab/plotly-extension > plotly.js > mapbox-gl > @mapbox/gl-matrix@0.0.1: This
warning @jupyterlab/plotly-extension > plotly.js > ndarray-fill > cwise > static-module > through2 > xtend > object-keys@0.4.0:
warning css-loader > cssnano > autoprefixer > browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
warning css-loader > cssnano > postcss-merge-rules > browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
warning css-loader > cssnano > postcss-merge-rules > caniuse-api > browserslist@1.7.7: Browserslist 2 could fail on reading Browserslist >3.0 config used in other tools.
[2/4] Fetching packages...
info fsevents@1.2.7: The platform "linux" is incompatible with this module.
info "fsevents@1.2.7" is an optional dependency and failed compatibility check. Excluding it from installation.
[3/4] Linking dependencies...
warning "@jupyterlab/vdom-extension > @nteract/transform-vdom@1.1.1" has incorrect peer dependency "react@^15.6.1".
[4/4] Building fresh packages...
success Saved lockfile.
Done in 64.03s.
node /srv/conda/lib/python3.6/site-packages/jupyterlab/staging/yarn.js run build
yarn run v1.9.4
$ webpack
(node:357) DeprecationWarning: Tapable.apply is deprecated. Call apply on the plugin directly instead
Hash: 15d8c7f7afeb9cf92268
Version: webpack 4.12.2
Time: 20280ms
Built at: 02/14/2019 9:10:18 PM
Asset Size Chunks Chunk Names
vega.0cdd647175d9a6042e69.js 517 bytes vega [emitted] vega
647d0c32c39d07754372.worker.js 1.45 MiB [emitted]
674f50d287a8c48dc19ba404d20fe713.eot 162 KiB [emitted]
44a526eed258222515aa21eaffd14a96.png 618 bytes [emitted]
af7ae505a9eed503f8b8e6982036873e.woff2 75.4 KiB [emitted]
bf677598a57b9539055834af51cf6062.png 290 bytes [emitted]
faa74e8c61fc64d5edb11613c7eead2c.gif 2.49 KiB [emitted]
a6137456ed160d7606981aa57c559898.png 696 bytes [emitted]
912ec66d7572ff821749319396470bde.svg 434 KiB [emitted]
fee66e712a8a08eef5805a46892932ad.woff 95.7 KiB [emitted]
401d815dc206b8dc1b17cd0e37695975.png 2.41 KiB [emitted]
2273e3d8ad9264b7daa5bdbf8e6b47f8.png 1.43 KiB [emitted]
b06871f281fee6b241d60582ae9369b9.ttf 162 KiB [emitted]
4f0283c6ce28e888000e978e537a6a56.png 1.23 KiB [emitted]
b2ffb3a32c2e07826c887815599de6f3.png 34.6 KiB [emitted]
main.fd1600f4ae5eac60fd97.js 59.7 KiB main [emitted] main
0.cc98107762fcc28532b3.js 4.5 KiB 0 [emitted]
647d0c32c39d07754372.worker.js.map 1.73 MiB [emitted]
vendors~@jupyter-widgets/controlsvega.3dd933b62461edbc58d8.js 22.6 KiB vendors@jupyter-widgets/controlsvega [emitted] vendors@jupyter-widgets/controlsvega
vendors
main.34895799119cf98d4399.js 17.6 MiB vendorsmain [emitted] vendorsmain
vendorsvega.a42e5d63f30681493c9e.js 3 MiB vendorsvega [emitted] vendorsvega
1.055322dcf6c2bb19185f.js 888 KiB 1 [emitted]
vendors
@jupyter-widgets/controls.0f2eb7a143368d9383d4.js 268 KiB vendors~@jupyter-widgets/controls [emitted] vendors~@jupyter-widgets/controls
2.9f854dc15a7a8d2ec003.js 1.44 MiB 2 [emitted]
main.fd1600f4ae5eac60fd97.js.map 69.8 KiB main [emitted] main
0.cc98107762fcc28532b3.js.map 5.73 KiB 0 [emitted]
vega.0cdd647175d9a6042e69.js.map 251 bytes vega [emitted] vega
vendors~@jupyter-widgets/controlsvega.3dd933b62461edbc58d8.js.map 15.6 KiB vendors@jupyter-widgets/controlsvega [emitted] vendors@jupyter-widgets/controlsvega
vendors
main.34895799119cf98d4399.js.map 20.8 MiB vendorsmain [emitted] vendorsmain
vendorsvega.a42e5d63f30681493c9e.js.map 2.35 MiB vendorsvega [emitted] vendorsvega
1.055322dcf6c2bb19185f.js.map 1.04 MiB 1 [emitted]
vendors
@jupyter-widgets/controls.0f2eb7a143368d9383d4.js.map 306 KiB vendors~@jupyter-widgets/controls [emitted] vendors~@jupyter-widgets/controls
2.9f854dc15a7a8d2ec003.js.map 1.72 MiB 2 [emitted]
index.html 1.53 KiB [emitted]
Entrypoint main = vendorsmain.34895799119cf98d4399.js vendorsmain.34895799119cf98d4399.js.map main.fd1600f4ae5eac60fd97.js main.fd1600f4ae5eac60fd97.js.map
[0] multi whatwg-fetch ./build/index.out.js 40 bytes {main} [built]
[1] vertx (ignored) 15 bytes {main} [optional] [built]
[4] buffer (ignored) 15 bytes {main} [optional] [built]
[5] crypto (ignored) 15 bytes {main} [optional] [built]
[6] readable-stream (ignored) 15 bytes {main} [built]
[7] node-fetch (ignored) 15 bytes {vega} [built]
[8] fs (ignored) 15 bytes {vega} [built]
[9] fs (ignored) 15 bytes {main} [built]
[10] http (ignored) 15 bytes {main} [built]
[ANye] ./build/index.out.js 40.9 KiB {main} [built]
[RnhZ] ./node_modules/moment/locale sync ^./.$ 2.88 KiB {main} [optional] [built]
[11] https (ignored) 15 bytes {main} [built]
[YuTi] (webpack)/buildin/module.js 497 bytes {vendors~main} [built]
[eTbV] ./node_modules/codemirror/mode sync ^./.
.js$ 2.78 KiB {0} [built]
[yLpj] (webpack)/buildin/global.js 489 bytes {vendors~main} [built]
+ 2764 hidden modules

WARNING in d3-array
Multiple versions of d3-array found:
1.2.4 .//d3-scale//d3-array from .//d3-scale//d3-array/src/index.js
2.0.3 .//d3-array from .//d3-array/src/index.js

WARNING in jquery
Multiple versions of jquery found:
2.2.4 .//jupyter-matplotlib//jquery from .//jupyter-matplotlib/src/mpl_widget.js
3.3.1 ./
/jquery from ./~/jquery-ui/ui/widget.js

WARNING in react
Multiple versions of react found:
15.6.2 .//@jupyterlab/git//react from .//@jupyterlab/git//react/lib/React.js
16.2.0 .//@jupyterlab/latex//react from .//@jupyterlab/latex//react/index.js
16.4.2 .//react from .//react/index.js

WARNING in react-dom
Multiple versions of react-dom found:
15.6.2 .//@jupyterlab/git//react-dom from .//@jupyterlab/git//react-dom/lib/ReactMount.js
16.2.1 .//@jupyterlab/latex//react-dom from .//@jupyterlab/latex//react-dom/index.js
16.4.2 .//react-dom from .//react-dom/index.js

Check how you can resolve duplicate packages:
https://github.com/darrenscerri/duplicate-package-checker-webpack-plugin#resolving-duplicate-packages-in-your-bundle

Child html-webpack-plugin for "index.html":
1 asset
Entrypoint undefined = index.html
[KTNU] ./node_modules/html-loader!./templates/partial.html 567 bytes {0} [built]
[YuTi] (webpack)/buildin/module.js 497 bytes {0} [built]
[aS2v] ./node_modules/html-webpack-plugin/lib/loader.js!./templates/template.html 1.22 KiB {0} [built]
[yLpj] (webpack)/buildin/global.js 489 bytes {0} [built]
+ 1 hidden module
Child worker:
Asset Size Chunks Chunk Names
647d0c32c39d07754372.worker.js 1.45 MiB main [emitted] main
647d0c32c39d07754372.worker.js.map 1.73 MiB main [emitted] main
Entrypoint main = 647d0c32c39d07754372.worker.js 647d0c32c39d07754372.worker.js.map
[yLpj] (webpack)/buildin/global.js 489 bytes {main} [built]
+ 2 hidden modules
Done in 21.67s.

Almost all of this conveys no useful information, and some of it is in red even though it's not an error.

Ideally, it should be a lot quieter - outputting errors only if / when things fail.

@vidartf
Copy link
Member

@vidartf vidartf commented Feb 15, 2019

I agree a lot of this could go behind a verbose/debug flag. This was on by default as initially there were quite a few errors with this. Now that things seem more stable, most of this could be silent by default.

On the side, it does seem from your output that you have some actual dependency conflicts. Is this unexpected?

@jasongrout jasongrout added this to the Future milestone Feb 15, 2019
@jasongrout
Copy link
Contributor

@jasongrout jasongrout commented Feb 15, 2019

I agree a lot of this could go behind a verbose/debug flag.

+1

@yuvipanda
Copy link
Contributor Author

@yuvipanda yuvipanda commented Feb 16, 2019

@vidartf no idea if this is expected :D I was just installing 'em without any particular version pinning

@vidartf
Copy link
Member

@vidartf vidartf commented Feb 18, 2019

Looking over the output, the current output makes sense as debug/verbose output. What it is saying is roughly:

  • I see that you want @jupyterlab/hub-extension.
  • I had a look at the content of the latest version (0.12), and it seems that it is incompatible with the current version of jupyterlab (0.12 is too new).
  • I found a version that is compatible (0.11), so I will install that instead.

Regarding resolution: I could help write up code to resolve this, but I'd like someone else to chime in on what the correct way should be to specify the verbosity level, and what the default level should be.

@javabrett
Copy link

@javabrett javabrett commented Mar 11, 2019

Is it worthwhile having a separate issue (if so I'll raise one) for this conflict:

warning "@jupyterlab/vdom-extension > @nteract/transform-vdom@1.1.1" has incorrect peer dependency "react@^15.6.1".

vdom-extension is self-conflicting with compatible version of react transient via @nteract/transform-vdom@1.1.1.

https://github.com/javabrett/jupyterlab/blob/86ac08051d573af947c4a51554a85fd5abf96246/packages/vdom-extension/package.json#L34

If @nteract/transform-vdom@1.1.1 could be revved to say 2.2.1 or later then they would both expect react 16.x.

https://github.com/nteract/nteract/blob/0701ddebe6c5cc1749ef91db8e3b696515cf9535/packages/transform-vdom/package.json#L21

@jasongrout
Copy link
Contributor

@jasongrout jasongrout commented Mar 11, 2019

I think it's worth a separate issue. Thanks!

@lock
Copy link

@lock lock bot commented Aug 6, 2019

This thread has been automatically locked since there has not been any recent activity after it was closed. Please open a new issue for related discussion.

@lock lock bot locked as resolved and limited conversation to collaborators Aug 6, 2019
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

4 participants