Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

"@jupyter-widgets/jupyterlab-manager" is not a valid npm package #6759

Closed
david-waterworth opened this issue Jul 4, 2019 · 2 comments

Comments

@david-waterworth
Copy link

@david-waterworth david-waterworth commented Jul 4, 2019

Since updateing to version 1.1 ( from a release candidate) I'm getting the following error:

jupyter labextension install @jupyter-widgets/jupyterlab-manager

An error occured.
ValueError: "@jupyter-widgets/jupyterlab-manager" is not a valid npm package

Not sure if it's using a cached version? Is there a way of forcing download of the latest, or is jupyter-widgets not been updated yet? (I've updated to ipywidgets-7.5.0)

@david-waterworth

This comment has been minimized.

Copy link
Author

@david-waterworth david-waterworth commented Jul 5, 2019

I've worked it out

jupyter labextension install @jupyter-widgets/jupyterlab-manager --debug

Error: EACCES: permission denied, mkdir '/home/david/.npm/_cacache/index-v5/17/5a'

For some reason I don't have write access to ~/.npm

After I fixed the fs permissions the error went away

@vidartf

This comment has been minimized.

Copy link
Member

@vidartf vidartf commented Jul 8, 2019

Thanks for reporting back with the root cause and remediation of your issue! Closing as resolved then.

@vidartf vidartf closed this Jul 8, 2019
@vidartf vidartf added this to the Reference milestone Jul 8, 2019
@lock lock bot locked as resolved and limited conversation to collaborators Aug 7, 2019
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
2 participants
You can’t perform that action at this time.