Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

fix python versions of build wheels by removing the universal flag #5287

Merged

Conversation

@bjoernmeier
Copy link
Contributor

@bjoernmeier bjoernmeier commented Sep 10, 2018

Hi,
currently the built wheel files still have the extension py2.py3-none-any.whl indicating python2 and python3 compatibility (for example jupyterlab-0.34.8-py2.py3-none-any.whl). As jupyterlab is python3 only since 40530f8 this pull requests removes the universal flag as it indicates that both versions are supported (see https://wheel.readthedocs.io/en/stable/#defining-the-python-version).
This will result in wheels like jupyterlab-0.35.0a0-py3-none-any.whl.

Copy link
Member

@blink1073 blink1073 left a comment

Thanks!

@blink1073 blink1073 added this to the 0.34.x milestone Sep 10, 2018
@blink1073 blink1073 merged commit a33fa44 into jupyterlab:master Sep 11, 2018
2 checks passed
@jasongrout jasongrout removed this from the 0.34.x milestone Oct 1, 2018
@jasongrout jasongrout added this to the 0.35 milestone Oct 1, 2018
@lock lock bot locked as resolved and limited conversation to collaborators Aug 8, 2019
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

3 participants