Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update to Vega 5 #6133

Merged
merged 12 commits into from Mar 25, 2019
Merged

Update to Vega 5 #6133

merged 12 commits into from Mar 25, 2019

Conversation

@domoritz
Copy link
Member

@domoritz domoritz commented Mar 25, 2019

Fixes #6128

I moved the existing extension package to jupyterlab/jupyter-renderers#184

@jupyterlab-dev-mode
Copy link

@jupyterlab-dev-mode jupyterlab-dev-mode bot commented Mar 25, 2019

Thanks for making a pull request to JupyterLab!

To try out this branch on binder, follow this link: Binder

@domoritz
Copy link
Member Author

@domoritz domoritz commented Mar 25, 2019

I believe things are correct but we need another npm release of the new package I added. Can someone help me with that?

@domoritz domoritz changed the title Update to Vega 5. Update to Vega 5 Mar 25, 2019
Copy link
Member

@ian-r-rose ian-r-rose left a comment

Thanks @domoritz!

@ian-r-rose ian-r-rose merged commit cba7c89 into jupyterlab:master Mar 25, 2019
9 checks passed
@domoritz domoritz deleted the vega5 branch Mar 25, 2019
"vega-embed": "3.18.2"
"vega": "^5.3.1",
"vega-embed": "^4.0.0",
"vega-lite": "^3.0.0"
Copy link
Member

@ian-r-rose ian-r-rose Mar 30, 2019

@domoritz Do these need to be specified here for any reason, or are the vega and vega-lite pulled in by vega-embed sufficient?

Copy link
Member Author

@domoritz domoritz Mar 30, 2019

Vega-Embed now only has peer dependencies. I think it's much better for you to be able to specify the versions you want regardless of the Vega-Embed version.

Copy link
Member

@ian-r-rose ian-r-rose Mar 30, 2019

Cool, thanks.

Copy link
Member Author

@domoritz domoritz Mar 30, 2019

Discussion is here: vega/vega-embed#136

@jasongrout jasongrout mentioned this pull request Apr 11, 2019
@jasongrout jasongrout added this to the 1.0 milestone Apr 11, 2019
@lock lock bot locked as resolved and limited conversation to collaborators Aug 7, 2019
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

3 participants