Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 46 lines (38 sloc) 1.925 kb
433dae2 @yabawock Whitespace Cleanup
yabawock authored
1 # encoding: utf-8
2
350bf0a @justinfrench first cut of a gem rake task, gemspec and version 0.1.0 gem (I hope)
authored
3 Gem::Specification.new do |s|
4 s.name = %q{formtastic}
a986b88 @justinfrench version bump
authored
5 s.version = "1.2.3"
6 s.date = %q{2011-01-07}
350bf0a @justinfrench first cut of a gem rake task, gemspec and version 0.1.0 gem (I hope)
authored
7
335dc77 @justinfrench new gemspec
authored
8 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
350bf0a @justinfrench first cut of a gem rake task, gemspec and version 0.1.0 gem (I hope)
authored
9 s.authors = ["Justin French"]
10 s.description = %q{A Rails form builder plugin/gem with semantically rich and accessible markup}
791b477 @justinfrench simplified the shit out of the gemspec
authored
11 s.summary = %q{A Rails form builder plugin/gem with semantically rich and accessible markup}
350bf0a @justinfrench first cut of a gem rake task, gemspec and version 0.1.0 gem (I hope)
authored
12 s.email = %q{justin@indent.com.au}
791b477 @justinfrench simplified the shit out of the gemspec
authored
13 s.extra_rdoc_files = ["README.textile"]
4490068 @justinfrench added init.rb and rails/* to the files included in the gem (#439, #433)
authored
14 s.files = Dir.glob("generators/**/*") + Dir.glob("lib/**/*") + Dir.glob("rails/*") + %w(MIT-LICENSE README.textile init.rb)
350bf0a @justinfrench first cut of a gem rake task, gemspec and version 0.1.0 gem (I hope)
authored
15 s.homepage = %q{http://github.com/justinfrench/formtastic/tree/master}
eed8b71 @justinfrench added a post_install_message to rake task/gemspec
authored
16 s.post_install_message = %q{
17 ========================================================================
18 Thanks for installing Formtastic!
b361e70 @justinfrench fixed activesupport and actionpack dependencies, generated a new gemspec
authored
19 ------------------------------------------------------------------------
8668583 @justinfrench new gemspec
authored
20 You can now (optionally) run the generator to copy some stylesheets and
eed8b71 @justinfrench added a post_install_message to rake task/gemspec
authored
21 a config initializer into your application:
59cc0d8 @justinfrench remove Rails 2 from gemspec
authored
22 rails generate formtastic:install
eed8b71 @justinfrench added a post_install_message to rake task/gemspec
authored
23
d6a9dcf exisiting -> existing
Carl Douglas authored
24 To generate some semantic form markup for your existing models, just run:
59cc0d8 @justinfrench remove Rails 2 from gemspec
authored
25 rails generate formtastic:form MODEL_NAME
b361e70 @justinfrench fixed activesupport and actionpack dependencies, generated a new gemspec
authored
26
2129d29 @justinfrench new gemspec and bumped version to 0.9.2
authored
27 Find out more and get involved:
eed8b71 @justinfrench added a post_install_message to rake task/gemspec
authored
28 http://github.com/justinfrench/formtastic
29 http://groups.google.com.au/group/formtastic
77bc879 @justinfrench added twitter to gem install welcome note
authored
30 http://twitter.com/formtastic
eed8b71 @justinfrench added a post_install_message to rake task/gemspec
authored
31 ========================================================================
32 }
fb507a2 @justinfrench Bumped gem version to 0.1.8, which includes three major changes:
authored
33 s.rdoc_options = ["--charset=UTF-8"]
350bf0a @justinfrench first cut of a gem rake task, gemspec and version 0.1.0 gem (I hope)
authored
34 s.require_paths = ["lib"]
eeba8d4 @justinfrench new gemspec
authored
35 s.rubygems_version = %q{1.3.6}
350bf0a @justinfrench first cut of a gem rake task, gemspec and version 0.1.0 gem (I hope)
authored
36
59cc0d8 @justinfrench remove Rails 2 from gemspec
authored
37 s.add_dependency(%q<rails>, ["~> 3.0.0"])
38
133dc81 @justinfrench Attempt to get rspec 2 working with Rails 2 and Rails 3.
authored
39 s.add_development_dependency(%q<rspec-rails>, ["~> 2.0.0"])
791b477 @justinfrench simplified the shit out of the gemspec
authored
40 s.add_development_dependency(%q<rspec_tag_matchers>, [">= 1.0.0"])
f53d440 @dbackeus Add hpricot as development dependency.
dbackeus authored
41 s.add_development_dependency(%q<hpricot>, ["~> 0.8.3"])
649bc6b @justinfrench add BlueCloth to dev deps
authored
42 s.add_development_dependency(%q<BlueCloth>) # for YARD
cb2f045 @justinfrench add YARD to development dependencies, some basic .yardopts, and ignore s...
authored
43 s.add_development_dependency(%q<yard>, ["~> 0.6"])
350bf0a @justinfrench first cut of a gem rake task, gemspec and version 0.1.0 gem (I hope)
authored
44
45 end
Something went wrong with that request. Please try again.