Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 40 lines (33 sloc) 1.671 kb
433dae2 @yabawock Whitespace Cleanup
yabawock authored
1 # encoding: utf-8
7f01af4 @kou switch to gemspec generated by bundler. #535 #548
kou authored
2 $:.push File.expand_path("../lib", __FILE__)
3 require "formtastic/version"
433dae2 @yabawock Whitespace Cleanup
yabawock authored
4
350bf0a @justinfrench first cut of a gem rake task, gemspec and version 0.1.0 gem (I hope)
authored
5 Gem::Specification.new do |s|
7f01af4 @kou switch to gemspec generated by bundler. #535 #548
kou authored
6 s.name = %q{formtastic}
7 s.version = Formtastic::VERSION
8 s.platform = Gem::Platform::RUBY
9 s.authors = [%q{Justin French}]
10 s.email = [%q{justin@indent.com.au}]
ab530b7 @justinfrench bumped the version to 2.0.0.rc1
authored
11 s.homepage = %q{http://github.com/justinfrench/formtastic}
7f01af4 @kou switch to gemspec generated by bundler. #535 #548
kou authored
12 s.summary = %q{A Rails form builder plugin/gem with semantically rich and accessible markup}
350bf0a @justinfrench first cut of a gem rake task, gemspec and version 0.1.0 gem (I hope)
authored
13 s.description = %q{A Rails form builder plugin/gem with semantically rich and accessible markup}
7f01af4 @kou switch to gemspec generated by bundler. #535 #548
kou authored
14
15 s.files = `git ls-files`.split("\n")
16 s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
17 s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
18 s.require_paths = ["lib"]
19
fb507a2 @justinfrench Bumped gem version to 0.1.8, which includes three major changes:
authored
20 s.rdoc_options = ["--charset=UTF-8"]
7f01af4 @kou switch to gemspec generated by bundler. #535 #548
kou authored
21 s.extra_rdoc_files = ["README.textile"]
22
23 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
eeba8d4 @justinfrench new gemspec
authored
24 s.rubygems_version = %q{1.3.6}
350bf0a @justinfrench first cut of a gem rake task, gemspec and version 0.1.0 gem (I hope)
authored
25
f39d1bd @twalpole Revert "Revert "Merge pull request #820 from twalpole/rails4""
twalpole authored
26 s.add_dependency(%q<actionpack>, [">= 3.0"])
59cc0d8 @justinfrench remove Rails 2 from gemspec
authored
27
62ba2f7 @justinfrench use rspec 2.8 final
authored
28 s.add_development_dependency(%q<rspec-rails>, ["~> 2.8.0"])
791b477 @justinfrench simplified the shit out of the gemspec
authored
29 s.add_development_dependency(%q<rspec_tag_matchers>, [">= 1.0.0"])
f53d440 @dbackeus Add hpricot as development dependency.
dbackeus authored
30 s.add_development_dependency(%q<hpricot>, ["~> 0.8.3"])
649bc6b @justinfrench add BlueCloth to dev deps
authored
31 s.add_development_dependency(%q<BlueCloth>) # for YARD
cb2f045 @justinfrench add YARD to development dependencies, some basic .yardopts, and ignore s...
authored
32 s.add_development_dependency(%q<yard>, ["~> 0.6"])
050ef12 @justinfrench Added new rcov tasks, made spec_and_verify_coverage the default rake tas...
authored
33 s.add_development_dependency(%q<rcov>, ["~> 0.9.9"])
34 s.add_development_dependency(%q<colored>)
0c119b4 @sobrinho Add tzinfo as development dependency
sobrinho authored
35 s.add_development_dependency(%q<tzinfo>)
50836dd @yabawock Update development dependencies to remove most deprecation warnings
yabawock authored
36 s.add_development_dependency(%q<ammeter>, ["~> 0.2.2"])
6c57b54 @yabawock Test formtastic with Rails 3.0-3.2 using appraisals
yabawock authored
37 s.add_development_dependency(%q<appraisal>)
38 s.add_development_dependency(%q<rake>)
350bf0a @justinfrench first cut of a gem rake task, gemspec and version 0.1.0 gem (I hope)
authored
39 end
Something went wrong with that request. Please try again.