Skip to content
Newer
Older
100644 31 lines (30 sloc) 702 Bytes
b117ad1 @twalpole update build matrix for rails 4.0.0.beta1 and ruby 2.0.0
twalpole authored
1 before_install:
2 - gem update --system
3 - gem update bundler
3fc2190 Add a basic .travis.yml file
beawesomeinstead authored
4 rvm:
5 - 1.8.7
2bb0234 @joshk Now that formtastic is green, why not add some more rubies! :)
joshk authored
6 - ree
b66cb77 @justinfrench Remove coverage requirement for 1.9.2 & 1.9.3, add back to Travis.
authored
7 - 1.9.2
8 - 1.9.3
4145374 @twalpole Update build matrix to not test ruby 1.8.7 and ree with rails 4 (edge)
twalpole authored
9 gemfile:
10 - gemfiles/rails-3.0.gemfile
11 - gemfiles/rails-3.1.gemfile
12 - gemfiles/rails-3.2.gemfile
ac48a50 @justinfrench set DEFER_GC=false env for Travis CI
authored
13 env:
e357a03 @justinfrench RAILS_EDGE=true is not a separate part of the CI matrix
authored
14 - DEFER_GC=false RAILS_EDGE=true
4145374 @twalpole Update build matrix to not test ruby 1.8.7 and ree with rails 4 (edge)
twalpole authored
15 script: "rake spec"
16 matrix:
b117ad1 @twalpole update build matrix for rails 4.0.0.beta1 and ruby 2.0.0
twalpole authored
17 include:
18 - rvm: 1.9.3
4145374 @twalpole Update build matrix to not test ruby 1.8.7 and ree with rails 4 (edge)
twalpole authored
19 gemfile: gemfiles/rails-4.gemfile
e357a03 @justinfrench RAILS_EDGE=true is not a separate part of the CI matrix
authored
20 env: DEFER_GC=false RAILS_EDGE=true
b117ad1 @twalpole update build matrix for rails 4.0.0.beta1 and ruby 2.0.0
twalpole authored
21 - rvm: 2.0.0
4d7c0ad @twalpole rails edge requires 1.9.3 so exclude testing with 1.9.2
twalpole authored
22 gemfile: gemfiles/rails-4.gemfile
e357a03 @justinfrench RAILS_EDGE=true is not a separate part of the CI matrix
authored
23 env: DEFER_GC=false RAILS_EDGE=true
3cbc35b @twalpole satisfy a rails4 warning, and allow failures for rails 4 tests in travis
twalpole authored
24 allow_failures:
25 - rvm: 1.9.3
26 gemfile: gemfiles/rails-4.gemfile
27 env: DEFER_GC=false RAILS_EDGE=true
b117ad1 @twalpole update build matrix for rails 4.0.0.beta1 and ruby 2.0.0
twalpole authored
28 - rvm: 2.0.0
29 gemfile: gemfiles/rails-4.gemfile
30 env: DEFER_GC=false RAILS_EDGE=true
Something went wrong with that request. Please try again.