Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Make testsuite work with Rails 3.0.0.rc and RSpec 2.0.0.beta19

  • Loading branch information...
commit 229eb53a626bb2c5272a4e7eee0b6f3210dd3c45 1 parent dd4651c
@yabawock yabawock authored
Showing with 6 additions and 4 deletions.
  1. +2 −2 spec/spec_helper.rb
  2. +4 −2 spec/support/test_environment.rb
View
4 spec/spec_helper.rb
@@ -17,6 +17,7 @@
module FormtasticSpecHelper
include ActionPack
include ActionView::Context if defined?(ActionView::Context)
+ include ActionController::RecordIdentifier
include ActionView::Helpers::FormHelper
include ActionView::Helpers::FormTagHelper
include ActionView::Helpers::FormOptionsHelper
@@ -25,12 +26,11 @@ module FormtasticSpecHelper
include ActionView::Helpers::TextHelper
include ActionView::Helpers::ActiveRecordHelper if defined?(ActionView::Helpers::ActiveRecordHelper)
include ActionView::Helpers::ActiveModelHelper if defined?(ActionView::Helpers::ActiveModelHelper)
- include ActionView::Helpers::RecordIdentificationHelper
include ActionView::Helpers::DateHelper
include ActionView::Helpers::CaptureHelper
include ActionView::Helpers::AssetTagHelper
include ActiveSupport
- include ActionController::PolymorphicRoutes
+ include ActionController::PolymorphicRoutes if defined?(ActionController::PolymorphicRoutes)
include Formtastic::SemanticFormHelper
View
6 spec/support/test_environment.rb
@@ -1,6 +1,6 @@
if Formtastic::Util.rails3?
- gem 'rspec', '~> 2.0.0.beta12'
- gem 'rspec-rails', '~> 2.0.0.beta12'
+ gem 'rspec', '~> 2.0.0.beta19'
+ gem 'rspec-rails', '~> 2.0.0.beta19'
gem 'rspec_tag_matchers'
gem 'i18n', '>= 0.4.0'
@@ -17,6 +17,7 @@ module FormtasticTest
class Application < Rails::Application
# Configure the default encoding used in templates for Ruby 1.9.
config.encoding = "utf-8"
+ config.active_support.deprecation = :stderr
end
end
FormtasticTest::Application.initialize!
@@ -33,6 +34,7 @@ class Application < Rails::Application
gem 'rspec-rails', '>= 1.2.6'
gem 'rspec_tag_matchers'
gem 'hpricot', '>= 0.6.1'
+ gem 'i18n', '< 0.4.0'
require 'rspec_tag_matchers'
Please sign in to comment.
Something went wrong with that request. Please try again.