Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

first cut of a gem rake task, gemspec and version 0.1.0 gem (I hope)

  • Loading branch information...
commit 350bf0a245292ebab0e286a8473bfcf9255c28f8 1 parent 80eff9a
@justinfrench authored
Showing with 59 additions and 0 deletions.
  1. +24 −0 Rakefile
  2. +4 −0 VERSION.yml
  3. +31 −0 formtastic.gemspec
View
24 Rakefile
@@ -2,6 +2,30 @@ require 'rake'
require 'rake/rdoctask'
require 'spec/rake/spectask'
+begin
+ GEM = "formtastic"
+ AUTHOR = "Justin French"
+ EMAIL = "justin@indent.com.au"
+ SUMMARY = "A Rails form builder plugin/gem with semantically rich and accessible markup"
+ HOMEPAGE = "http://github.com/justinfrench/formtastic/tree/master"
+
+ require 'jeweler'
+ Jeweler::Tasks.new do |s|
+ s.name = GEM
+ s.summary = SUMMARY
+ s.email = EMAIL
+ s.homepage = HOMEPAGE
+ s.description = SUMMARY
+ s.author = AUTHOR
+
+ s.require_path = 'lib'
+ s.autorequire = GEM
+ s.files = %w(MIT-LICENSE README.textile Rakefile) + Dir.glob("{rails,lib,spec}/**/*")
+ end
+rescue LoadError
+ puts "Jeweler, or one of its dependencies, is not available. Install it with: sudo gem install technicalpickles-jeweler -s http://gems.github.com"
+end
+
desc 'Default: run unit specs.'
task :default => :spec
View
4 VERSION.yml
@@ -0,0 +1,4 @@
+---
+:major: 0
+:minor: 1
+:patch: 0
View
31 formtastic.gemspec
@@ -0,0 +1,31 @@
+# -*- encoding: utf-8 -*-
+
+Gem::Specification.new do |s|
+ s.name = %q{formtastic}
+ s.version = "0.1.1"
+
+ s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
+ s.authors = ["Justin French"]
+ s.autorequire = %q{formtastic}
+ s.date = %q{2009-03-08}
+ s.description = %q{A Rails form builder plugin/gem with semantically rich and accessible markup}
+ s.email = %q{justin@indent.com.au}
+ s.extra_rdoc_files = ["README.textile"]
+ s.files = ["MIT-LICENSE", "README.textile", "Rakefile", "rails/init.rb", "lib/formtastic.rb", "lib/justin_french", "lib/justin_french/formtastic.rb", "lib/locale", "lib/locale/en.yml", "spec/formtastic_spec.rb", "spec/test_helper.rb"]
+ s.has_rdoc = true
+ s.homepage = %q{http://github.com/justinfrench/formtastic/tree/master}
+ s.rdoc_options = ["--inline-source", "--charset=UTF-8"]
+ s.require_paths = ["lib"]
+ s.rubygems_version = %q{1.3.1}
+ s.summary = %q{A Rails form builder plugin/gem with semantically rich and accessible markup}
+
+ if s.respond_to? :specification_version then
+ current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
+ s.specification_version = 2
+
+ if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ else
+ end
+ else
+ end
+end
Please sign in to comment.
Something went wrong with that request. Please try again.