Permalink
Browse files

smart_require is tripping up the CI build, and also tripped me up a f…

…ew times, so let's try explicit lines that do what we need to do... specs pass with what I have here, the only real change is we're explicitly requiring Rails 2.3.5 components to explude Rails 3
  • Loading branch information...
1 parent b4fc852 commit 960494954b39a9ac439cb88d3ec90ac0b881a4d1 @justinfrench committed Feb 7, 2010
Showing with 12 additions and 18 deletions.
  1. +12 −18 spec/spec_helper.rb
View
@@ -1,24 +1,18 @@
# coding: utf-8
require 'rubygems'
-def smart_require(lib_name, gem_name, gem_version = '>= 0.0.0')
- begin
- require lib_name if lib_name
- rescue LoadError
- if gem_name
- gem gem_name, gem_version
- require lib_name if lib_name
- end
- end
-end
-
-smart_require 'spec', 'spec', '>= 1.2.6'
-smart_require false, 'rspec-rails', '>= 1.2.6'
-smart_require 'hpricot', 'hpricot', '>= 0.6.1'
-smart_require 'rspec_tag_matchers', 'rspec_tag_matchers', '>= 1.0.0'
-smart_require 'active_support', 'activesupport', '>= 2.3.4'
-smart_require 'action_controller', 'actionpack', '>= 2.3.4'
-smart_require 'action_view', 'actionpack', '>= 2.3.4'
+gem 'activesupport', '2.3.5'
+gem 'actionpack', '2.3.5'
+require 'active_support'
+require 'action_pack'
+require 'action_view'
+require 'action_controller'
+
+gem 'rspec', '>= 1.2.6'
+gem 'rspec-rails', '>= 1.2.6'
+gem 'hpricot', '>= 0.6.1'
+gem 'rspec_tag_matchers', '>= 1.0.0'
+require 'rspec_tag_matchers'
require 'custom_macros'

0 comments on commit 9604949

Please sign in to comment.