Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

ActiveSupport::OrderedHash not autoladed in Rails 4

  • Loading branch information...
commit ba055ccff074d5dd8d9ac73810811e006f370ade 1 parent 0b929a2
@twalpole twalpole authored
Showing with 1 addition and 0 deletions.
  1. +1 −0  spec/spec_helper.rb
View
1  spec/spec_helper.rb
@@ -6,6 +6,7 @@
require 'action_view'
require 'action_controller'
require 'action_dispatch'
+require 'active_support/ordered_hash' #Rails 4 no longer autoloads ActiveSupport::OrderedHash
require File.expand_path(File.join(File.dirname(__FILE__), '../lib/formtastic/util'))
require File.expand_path(File.join(File.dirname(__FILE__), '../lib/formtastic'))

4 comments on commit ba055cc

@rafaelfranca

I think that this change will be reverted at Rails. More info

@twalpole
Collaborator

If it is reverted I can revert the commit, right now it's needed for the tests to pass

@yabawock
Collaborator

Rails 4 won't need ordered hash since it drops Ruby 1.8 support

@twalpole
Collaborator

@yabawock Right - the question is whether they leave it in ActiveSupport for ease of backwards compatability in all the gems that will want to maintain Rails 3 and 4 compatibility in 1.8.x (for 3) and 1.9.3+, or if they remove it completely. If they remove it completely then there will need to be changes in the tests here. That being said it looks like tenderlove has reverted the removal of autoload so I'll revert this commit

Please sign in to comment.
Something went wrong with that request. Please try again.