Skip to content

still deprecated methods around in edge #38

Closed
masterkain opened this Issue Aug 24, 2009 · 3 comments

3 participants

@masterkain

formtastic.rb L#93, change to @object.errors[method.to_sym]
formtastic.rb L#382, change to @object.errors[method.to_sym]

@justinfrench
Owner

Thanks, do you mean edge as in Rails 3 edge? Haven't begun work on that at all yet.

Made these changes locally, heaps of failing specs, guessing this isn't a backwards compatible change with Rails 2.3 (which is what we support for now, not edge), so I'm going to tag this with 1.x and we can come back to it when edge settles down a bit, and we can implement something compatible with 2.x and 3.x (or whatever we're supporting at the time).

@masterkain

hi Justin,
sorry for the quick message but I was on hurry, yes, I mean rails edge and only edge, since I don't use stable versions at the moment, so I don't know if this change is part of 2.3-stable; but it have been 5 months since the commit, and other plugins started using the [] notation, so..
http://github.com/rails/rails/commit/37283a6aaec244cb484e24b3e9ff165e89eadd64

@josevalim

Done. I already has that in my fork!

This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.