init.rb and rails/ missing from 1.2.0 gem #439

Closed
jnimety opened this Issue Nov 15, 2010 · 6 comments

Projects

None yet

2 participants

@jnimety
jnimety commented Nov 15, 2010

These are required for rails 2.3.x, otherwise "ActionView::TemplateError (undefined method `semantic_form_for' for #ActionView::Base:0x779ee04)" errors happen

@justinfrench
Owner

I don't understand why I can't repeat this error on my own 2.3.9 app, but I can see that this could cause a problem, so thanks for finding the likely cause. Expect a beta 1.2.1.beta for testing within 24 hours, would appreciate your help confirming it resolves your problems.

@jnimety
jnimety commented Nov 15, 2010

we're using 2.3.10 with bundler and a ton of gem dependencies, so maybe there's some complex interaction going on. I manually copied init.rb and rails/ from 1.1.0 gem dir to the 1.2.0 gem dir and it fixed the issue.

I'll be sure to test the beta when it's available, thanks for the quick response.

@justinfrench
Owner

this is also a duplicate of #433, for the record

@justinfrench
Owner

Ok, 1.2.1.beta has been pushed, please test!

@justinfrench
Owner

confirmed to be working in #433, closing

@jnimety
jnimety commented Nov 16, 2010

confirmed, thanks!

This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment