rails 2.3.14 / gem 1.8.24 / formtastic 1.x "missing gem" #908

Closed
thoraxe opened this Issue Jan 5, 2013 · 4 comments

Comments

Projects
None yet
1 participant

thoraxe commented Jan 5, 2013

So I'm trying to update an old rails app from 2.2 to 2.3.14, and seem to be running into a few issues.

If I use gem 1.3.7 everything is fine. 1.8.24 and 1.7.2 both end up with the same kind of issue:

Missing these required gems:
  formtastic  = 1.2.5

You're running:
  ruby 1.8.7.371 at /home/riding/.rvm/rubies/ruby-1.8.7-p371/bin/ruby
  rubygems 1.8.24 at /home/riding/.rvm/gems/ruby-1.8.7-p371@rr-2.3, /home/riding/.rvm/gems/ruby-1.8.7-p371@global

Formtastic is definitely installed:

1.8.7@rr-2.3:Riding-Resource [rails2311] $ gem list | grep formt
formtastic (2.2.1, 1.2.5, 1.0.1)

If I comment out formtastic, no other gems cause this issue. Something appears to be a little fishy here, but I'm not sure exactly what. I'll try some newer versions of gem to see what happens.

thoraxe commented Jan 5, 2013

1.5.3 is the newest version of gem where I don't get this error.

Once I go to 1.6.0, I get the error.

thoraxe commented Jan 5, 2013

1.8.7@rr-2.3:Riding-Resource [rails2311] $ irb
1.8.7-p371 :001 > require 'rubygems'
 => true 
1.8.7-p371 :002 > require 'formtastic'
NameError: uninitialized constant Formtastic::I18n::YAML
        from /home/riding/.rvm/gems/ruby-1.8.7-p371@rr-2.3/gems/formtastic-1.2.5/lib/formtastic/i18n.rb:7
        from /home/riding/.rvm/rubies/ruby-1.8.7-p371/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require'
        from /home/riding/.rvm/rubies/ruby-1.8.7-p371/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
        from /home/riding/.rvm/gems/ruby-1.8.7-p371@rr-2.3/gems/formtastic-1.2.5/lib/formtastic.rb:2
        from /home/riding/.rvm/rubies/ruby-1.8.7-p371/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:60:in `gem_original_require'
        from /home/riding/.rvm/rubies/ruby-1.8.7-p371/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:60:in `require'
        from (irb):2

thoraxe commented Jan 5, 2013

sorry, this is a little better:

1.8.7@rr-2.3:Riding-Resource [rails2311] $ irb
1.8.7-p371 :001 > require 'rubygems'
 => true 
1.8.7-p371 :002 > require 'yaml'
 => true 
1.8.7-p371 :003 > require 'formtastic'
NameError: uninitialized constant Formtastic::ActionView
        from /home/riding/.rvm/gems/ruby-1.8.7-p371@rr-2.3/gems/formtastic-1.2.5/lib/formtastic.rb:8
        from /home/riding/.rvm/rubies/ruby-1.8.7-p371/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:60:in `gem_original_require'
        from /home/riding/.rvm/rubies/ruby-1.8.7-p371/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:60:in `require'
        from (irb):3

thoraxe commented Jan 5, 2013

After some digging, I got to this:

Gem::LoadError: Unable to activate formtastic-1.2.5, because i18n-0.6.1 conflicts with i18n (~> 0.4.0)

After removing the offending versions of i18n, I was able to make it all work:

1.8.7@rr-2.3:Riding-Resource [rails2311] $ irb
1.8.7-p371 :001 > require 'yaml'
 => true 
1.8.7-p371 :002 > require 'rubygems'
 => true 
1.8.7-p371 :003 > require 'action_view'
 => true 
1.8.7-p371 :004 > require 'formtastic'
 => [] 
1.8.7-p371 :005 > quit

Sorry for the noise. This is a PEBCAK issue.

@thoraxe thoraxe closed this Jan 5, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment