Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Add Ruby 2.1.0 to .travis.yml #982

Merged
merged 2 commits into from

3 participants

@salimane

No description provided.

@sobrinho
Collaborator

Hey @salimane, can you check why the build is failing?

@justinfrench
Owner

@salimane are you able to repeat the build fail locally? You could also add this in as an "allowed to fail" part of the matrix. We need to get it in there either way.

@salimane

@justinfrench @sobrinho I will check it again and report back

@salimane

I've tested locally. Some tests are failing on Rails 4 + MRI 2.1.0 . So I've added that combination to "allowed to fail" :)

@justinfrench justinfrench merged commit ead9700 into from
@salimane salimane deleted the branch
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Jan 8, 2014
  1. @salimane
Commits on Apr 1, 2014
  1. @salimane
This page is out of date. Refresh to see the latest.
Showing with 16 additions and 2 deletions.
  1. +16 −2 .travis.yml
View
18 .travis.yml
@@ -1,4 +1,4 @@
-before_install:
+before_install:
- gem update --system
- gem update bundler
rvm:
@@ -6,6 +6,8 @@ rvm:
- ree
- 1.9.2
- 1.9.3
+ - 2.0.0
+ - 2.1.0
gemfile:
- gemfiles/rails_3.0.gemfile
- gemfiles/rails_3.1.gemfile
@@ -21,12 +23,18 @@ matrix:
- rvm: 2.0.0
gemfile: gemfiles/rails_4.gemfile
env: DEFER_GC=false RAILS_EDGE=true
+ - rvm: 2.1.0
+ gemfile: gemfiles/rails_4.gemfile
+ env: DEFER_GC=false RAILS_EDGE=true
- rvm: 1.9.3
gemfile: gemfiles/rails_edge.gemfile
env: DEFER_GC=false RAILS_EDGE=true
- rvm: 2.0.0
gemfile: gemfiles/rails_edge.gemfile
- env: DEFER_GC=false RAILS_EDGE=true
+ env: DEFER_GC=false RAILS_EDGE=true
+ - rvm: 2.1.0
+ gemfile: gemfiles/rails_edge.gemfile
+ env: DEFER_GC=false RAILS_EDGE=true
allow_failures:
- rvm: 1.9.3
gemfile: gemfiles/rails_edge.gemfile
@@ -34,3 +42,9 @@ matrix:
- rvm: 2.0.0
gemfile: gemfiles/rails_edge.gemfile
env: DEFER_GC=false RAILS_EDGE=true
+ - rvm: 2.1.0
+ gemfile: gemfiles/rails_4.gemfile
+ env: DEFER_GC=false RAILS_EDGE=true
+ - rvm: 2.1.0
+ gemfile: gemfiles/rails_edge.gemfile
+ env: DEFER_GC=false RAILS_EDGE=true
Something went wrong with that request. Please try again.