Permalink
Browse files

added versin, new gemspec, tasks, etc from

  • Loading branch information...
1 parent 7f3ecb5 commit de84db53e69f9989fea3c920ffa20c64b24ebf23 @justinfrench committed May 29, 2011
Showing with 27 additions and 19 deletions.
  1. +2 −1 Gemfile
  2. +5 −1 Rakefile
  3. +3 −0 lib/nestive/version.rb
  4. +17 −17 nestive.gemspec
View
@@ -1,3 +1,4 @@
-source :rubygems
+source "http://rubygems.org"
+# Specify dependencies in nestive.gemspec
gemspec
View
@@ -1,6 +1,10 @@
#!/usr/bin/env rake
require 'rake/testtask'
-require 'rake/rdoctask'
+require 'rdoc/task'
+
+require 'bundler'
+Bundler::GemHelper.install_tasks
+
desc 'Default: run unit tests.'
task :default => :test
View
@@ -0,0 +1,3 @@
+module Nestive
+ VERSION = "0.0.1"
+end
View
@@ -1,23 +1,23 @@
-# encoding: utf-8
+# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require "nestive/version"
Gem::Specification.new do |s|
- s.name = %q{nestive}
- s.version = "0.0.1.pre"
- s.date = %q{2011-04-26}
-
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Justin French"]
+ s.name = "nestive"
+ s.version = Nestive::VERSION
+ s.platform = Gem::Platform::RUBY
+ s.authors = ["Justin French"]
+ s.email = ["justin@indent.com.au"]
+ s.homepage = ""
+ s.summary = %q{A Rails plugin/gem for awesome nested templates and layouts}
s.description = %q{A Rails plugin/gem for awesome nested templates and layouts}
- s.summary = %q{A Rails plugin/gem for awesome nested templates and layouts}
- s.email = %q{justin@indent.com.au}
- s.extra_rdoc_files = ["README"]
- s.files = Dir.glob("{app,lib}/**/*")
- s.homepage = %q{http://github.com/justinfrench/nestive}
- s.post_install_message = %q{}
- s.rdoc_options = ["--charset=UTF-8"]
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.6}
- s.add_dependency(%q<rails>, ["~> 3.0"])
+ s.rubyforge_project = "nestive"
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.require_paths = ["lib"]
+
+ s.add_dependency(%q<rails>, ["~> 3.0"])
end

0 comments on commit de84db5

Please sign in to comment.