Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Custom "from_phrase" and "subject" set in email theme templates not used with Full Layout #749

Closed
sandy-j opened this issue Jul 24, 2018 · 4 comments

Comments

@sandy-j
Copy link

commented Jul 24, 2018

Hi Justin,
When testing Pro Dada 11.1.0, I find that the "from_phrase" and "subject" set in email theme templates are not being picked up, although the "to_phrase" IS being used. But strangely, this problem ONLY shows with the Full Layout option selected. When using Minimal Layout, Discussion List layout, Old School etc. everything works correctly. This is similar to issue #734 but maybe not quite the same. Seems to apply to every theme that I've tried.
TIA
Sandy

@justingit

This comment has been minimized.

Copy link
Owner

commented Jul 24, 2018

Can you walk me through the process of how you set up the custom from_phrase and header in your testing?

@sandy-j

This comment has been minimized.

Copy link
Author

commented Jul 27, 2018

Hi Justin,
I'm just using the default Theme, which already has

   from_phrase: <!-- tmpl_var list_settings.list_name -->
   subject: <!-- tmpl_var list_settings.list_name --> Message

set up in the mailing_list_message.txt file. I haven't changed these. But they are not being picked up with the "Full layout" option, although they are picked up with every other Layout option. So the message comes from the list email address but with no List Name preceding it.
But the first line in mailing_list_message.txt, i.e.

to_phrase: <!-- tmpl_var list_settings.list_name --> Subscriber

IS being used, so the message comes with the correct "To" header, even with Full Layout.
Sandy

Repository owner deleted a comment from sandy-j Jul 27, 2018

@justingit

This comment has been minimized.

Copy link
Owner

commented Jul 27, 2018

Thanks for the clarification. I'll look over this, and see what I can find.

@justingit

This comment has been minimized.

Copy link
Owner

commented Jul 27, 2018

OK, I think I can recreate the problems you're seeing. Thanks for the report!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.