Skip to content
Browse files

move version to VERSION file

  • Loading branch information...
1 parent cf8a1a1 commit 4b8030c0c2f2b86894085995eb0330ce0b179b72 @dchelimsky dchelimsky committed Feb 20, 2010
Showing with 15 additions and 20 deletions.
  1. +2 −1 Rakefile
  2. +1 −0 VERSION
  3. +1 −10 lib/rspec/mocks/version.rb
  4. +11 −9 rspec-mocks.gemspec
View
3 Rakefile
@@ -10,7 +10,8 @@ begin
Jeweler::Tasks.new do |gem|
gem.name = "rspec-mocks"
gem.version = Rspec::Mocks::Version::STRING
- gem.summary = "rspec-mocks"
+ gem.summary = "rspec-mocks-#{Rspec::Mocks::Version::STRING}"
+ gem.description = "Rspec's 'test double' framework, with support for stubbing and mocking"
gem.email = "dchelimsky@gmail.com;chad.humphries@gmail.com"
gem.homepage = "http://github.com/rspec/mocks"
gem.authors = ["David Chelimsky", "Chad Humphries"]
View
1 VERSION
@@ -0,0 +1 @@
+2.0.0.a7
View
11 lib/rspec/mocks/version.rb
@@ -1,16 +1,7 @@
module Rspec # :nodoc:
module Mocks # :nodoc:
module Version # :nodoc:
- unless defined?(MAJOR)
- MAJOR = 2
- MINOR = 0
- TINY = 0
- PRE = 'a6'
-
- STRING = [MAJOR, MINOR, TINY, PRE].compact.join('.')
-
- SUMMARY = "rspec-mocks " + STRING
- end
+ STRING = File.read(File.expand_path('../../../../VERSION', __FILE__))
end
end
end
View
20 rspec-mocks.gemspec
@@ -5,11 +5,12 @@
Gem::Specification.new do |s|
s.name = %q{rspec-mocks}
- s.version = "2.0.0.a6"
+ s.version = "2.0.0.a7"
s.required_rubygems_version = Gem::Requirement.new("> 1.3.1") if s.respond_to? :required_rubygems_version=
s.authors = ["David Chelimsky", "Chad Humphries"]
- s.date = %q{2010-02-15}
+ s.date = %q{2010-02-20}
+ s.description = %q{Rspec's 'test double' framework, with support for stubbing and mocking}
s.email = %q{dchelimsky@gmail.com;chad.humphries@gmail.com}
s.extra_rdoc_files = [
"README.markdown"
@@ -20,6 +21,7 @@ Gem::Specification.new do |s|
"License.txt",
"README.markdown",
"Rakefile",
+ "VERSION",
"lib/rspec/mocks.rb",
"lib/rspec/mocks/argument_expectation.rb",
"lib/rspec/mocks/argument_matchers.rb",
@@ -84,7 +86,7 @@ Gem::Specification.new do |s|
s.rdoc_options = ["--charset=UTF-8"]
s.require_paths = ["lib"]
s.rubygems_version = %q{1.3.5}
- s.summary = %q{rspec-mocks}
+ s.summary = %q{rspec-mocks-2.0.0.a7}
s.test_files = [
"spec/rspec/mocks/and_yield_spec.rb",
"spec/rspec/mocks/any_number_of_times_spec.rb",
@@ -133,21 +135,21 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<rspec-core>, [">= 2.0.0.a6"])
- s.add_development_dependency(%q<rspec-expectations>, [">= 2.0.0.a6"])
+ s.add_development_dependency(%q<rspec-core>, [">= 2.0.0.a7"])
+ s.add_development_dependency(%q<rspec-expectations>, [">= 2.0.0.a7"])
s.add_development_dependency(%q<mocha>, [">= 0"])
s.add_development_dependency(%q<flexmock>, [">= 0"])
s.add_development_dependency(%q<rr>, [">= 0"])
else
- s.add_dependency(%q<rspec-core>, [">= 2.0.0.a6"])
- s.add_dependency(%q<rspec-expectations>, [">= 2.0.0.a6"])
+ s.add_dependency(%q<rspec-core>, [">= 2.0.0.a7"])
+ s.add_dependency(%q<rspec-expectations>, [">= 2.0.0.a7"])
s.add_dependency(%q<mocha>, [">= 0"])
s.add_dependency(%q<flexmock>, [">= 0"])
s.add_dependency(%q<rr>, [">= 0"])
end
else
- s.add_dependency(%q<rspec-core>, [">= 2.0.0.a6"])
- s.add_dependency(%q<rspec-expectations>, [">= 2.0.0.a6"])
+ s.add_dependency(%q<rspec-core>, [">= 2.0.0.a7"])
+ s.add_dependency(%q<rspec-expectations>, [">= 2.0.0.a7"])
s.add_dependency(%q<mocha>, [">= 0"])
s.add_dependency(%q<flexmock>, [">= 0"])
s.add_dependency(%q<rr>, [">= 0"])

0 comments on commit 4b8030c

Please sign in to comment.
Something went wrong with that request. Please try again.