Skip to content
This repository has been archived by the owner. It is now read-only.
master
Switch branches/tags
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
 
 
lib
 
 
src
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

MOVE TO https://github.com/denoland/vscode_deno/tree/master/typescript-deno-plugin


typescript-deno-plugin

Deno language service plugin for TypeScript.

npm package

Build Status NPM version NPM Downloads Install Size

Editor Support

This plugin requires TypeScript 2.3 or later. It can provide intellisense in TypeScript files within any editors that uses TypeScript to power their language features.

With VS Code

The simplest way to use this plugin is to install the TypeScript Deno Plugin VS Code extension. This extension enables the plugin when using VS Code's version of TypeScript.

If you are using a workspace version of TypeScript, you must manually install the plugin alongside the version of TypeScript in your workspace.

use npm:

npm install --save-dev typescript-deno-plugin typescript

or use yarn:

yarn add -D typescript-deno-plugin typescript

With JetBrains IDEs

Prerequisite: Follow manual installation instructions as described in VSCode install.

  1. Open TypScript preferences:

Preferences | Languages & Frameworks | TypeScript

  1. Change the TypeScript path to the local installed typescript path e.g. ~/myapp/node_modules/typescript

Tested with WebStorm. Hypothetically, should run in all JetBrains IDEs.

Configuration

After install typescript-deno-plugin, Then you can add a plugins section to your tsconfig.json.

{
  "compilerOptions": {
    "plugins": [
      {
        "name": "typescript-deno-plugin",
        "enable": true, // default is `true`
        "importmap": "import_map.json"
      }
    ]
  }
}

Finally, run the Select TypeScript version command in VS Code to switch to use the workspace version of TypeScript for VS Code's JavaScript and TypeScript language support. You can find more information about managing typescript versions in the VS Code documentation.

With Visual Studio

This plugin works Visual Studio 2017 using the TypeScript 2.3+ SDK.

First install the plugin in your project.

use npm:

npm install --save-dev typescript-deno-plugin typescript

or use yarn:

yarn add -D typescript-deno-plugin typescript

Then add a plugins section to your tsconfig.json.

{
  "compilerOptions": {
    "plugins": [
      {
        "name": "typescript-deno-plugin"
      }
    ]
  }
}

Then reload your project to make sure the plugin has been loaded properly.

With Atom

This plugin works with the Atom TypeScript plugin.

First install the plugin and a copy of TypeScript in your workspace.

use npm:

npm install --save-dev typescript-deno-plugin typescript

or use yarn:

yarn add -D typescript-deno-plugin typescript

Then add a plugins section to your tsconfig.json.

{
  "compilerOptions": {
    "plugins": [
      {
        "name": "typescript-deno-plugin"
      }
    ]
  }
}

Then restart Atom.

Credits

License

typescript-deno-plugin is released under the MIT License. See the bundled LICENSE file for details.