Permalink
Browse files

updated composer.json, license.md, readme.md

  • Loading branch information...
1 parent 550bcaa commit 0615a2f896a5ddc04578140c1f6fc189946f0587 @dg dg committed Sep 5, 2012
Showing with 73 additions and 78 deletions.
  1. +6 −2 composer.json
  2. +12 −12 license.txt → license.md
  3. +55 −0 readme.md
  4. +0 −64 readme.txt
View
8 composer.json
@@ -1,19 +1,23 @@
{
"name": "nette/nette",
+ "type": "library",
"description": "Nette Framework - innovative framework for fast and easy development of secured web applications in PHP. Write less, have cleaner code and your work will bring you joy.",
"keywords": ["framework", "mvc", "debugging", "templating", "database", "dbal", "forms", "latte", "neon", "mailing", "images", "micro"],
"homepage": "http://nette.org",
- "license": ["BSD-3", "GPLv2", "GPLv3"],
+ "license": ["BSD-3-Clause", "GPL-2.0", "GPL-3.0"],
"authors": [
{
"name": "David Grudl",
"homepage": "http://davidgrudl.com"
},
{
"name": "Nette Community",
- "homepage": "https://github.com/nette/nette/contributors"
+ "homepage": "http://nette.org/contributors"
}
],
+ "require": {
+ "php": ">=5.3.0"
+ },
"autoload": {
"files": ["Nette/loader.php"]
},
View
24 license.txt → license.md
@@ -39,16 +39,16 @@ are permitted provided that the following conditions are met:
may be used to endorse or promote products derived from this software
without specific prior written permission.
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
-ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
-ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
-LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON
-ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
-SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+This software is provided by the copyright holders and contributors "as is" and
+any express or implied warranties, including, but not limited to, the implied
+warranties of merchantability and fitness for a particular purpose are
+disclaimed. In no event shall the copyright owner or contributors be liable for
+any direct, indirect, incidental, special, exemplary, or consequential damages
+(including, but not limited to, procurement of substitute goods or services;
+loss of use, data, or profits; or business interruption) however caused and on
+any theory of liability, whether in contract, strict liability, or tort
+(including negligence or otherwise) arising in any way out of the use of this
+software, even if advised of the possibility of such damage.
@@ -58,5 +58,5 @@ GNU General Public License
GPL licenses are very very long, so instead of including them here we offer
you URLs with full text:
-- GPL version 2: http://www.gnu.org/licenses/gpl-2.0.html
-- GPL version 3: http://www.gnu.org/licenses/gpl-3.0.html
+- [GPL version 2](http://www.gnu.org/licenses/gpl-2.0.html)
+- [GPL version 3](http://www.gnu.org/licenses/gpl-3.0.html)
View
55 readme.md
@@ -0,0 +1,55 @@
+[Nette Framework](http://nette.org)
+===================================
+
+Nette Framework is a popular tool for PHP web development. It is designed to be
+the most usable and friendliest as possible. It focuses on security and
+performance and is definitely one of the safest PHP frameworks.
+
+Nette Framework speaks your language and helps you to easily build better websites.
+
+
+Requirements
+------------
+
+Nette Framework package for PHP 5.3 requires PHP 5.3.0 or later. The package
+for PHP 5.2 works with PHP 5.2.0 or later. Please run [Requirements
+Checker](http://doc.nette.org/requirements) to obtain more detailed information.
+
+
+Installation
+------------
+
+The best way to install Nette Framework is to download latest package from
+http://nette.org/download or use [Composer](http://doc.nette.org/composer).
+The downloaded package includes the following directories:
+
+- `Nette`: this directory contains the source code of Nette Framework. This is
+ the only directory that you will need in order to deploy your application.
+
+- `Nette-minified`: contains Nette Framework source code compressed into single file.
+
+- `client-side`: this directory contains the JavaScript source codes.
+
+- `API-reference`: generated API documentation for the framework in HTML format. These
+ files are build using Apidoc from the contents of the Nette directory.
+
+- `examples`: contains some Nette Framework demo applications.
+
+- `sandbox`: contains a pre-packaged Nette Framework project, basic configured
+ structure for your application.
+
+- `tests`: contains Nette Framework unit tests and testing tool.
+
+- `tools`: contains supporting tools as a Requirements Checker, script that can check
+ if your system meets the requirements for running Nette Framework.
+
+
+Getting started
+---------------
+
+The [Quick Start tutorial](http://doc.nette.org/quickstart) gives you a first
+introduction to the framework by creating a simple database driven application.
+
+-----
+
+[![Build Status](https://secure.travis-ci.org/nette/nette.png?branch=master)](http://travis-ci.org/nette/nette)
View
64 readme.txt
@@ -1,64 +0,0 @@
-Welcome to Nette Framework
-==========================
-
-Nette Framework is a powerful, component-based and event-driven framework
-for creating web applications and services in PHP 5.2 & 5.3. Nette Framework
-is designed with simplicity, speed and flexibility in mind. It allows developers
-to easily build better websites.
-
-Nette Framework focuses on security and performance and is definitely one of
-the safest and fastest PHP frameworks. Nette Framework supports the latest
-technologies and approaches like AJAX, HTML5, SEO, DRY, KISS, MVC, etc.
-
-
-Requirements
-------------
-
-Nette Framework package for PHP 5.2 requires PHP 5.2.0 or later. The package
-for PHP 5.3 requires PHP 5.3.0 or later. Please run "Requirements Checker"
-to obtain more detailed information.
-
-
-Installation
-------------
-
-After downloading the latest distribution package from http://nette.org/download,
-extract it to a directory accessible by web server. The installation is done!
-
-The source tree includes the following directories:
-
-- Nette: this directory contains the source code of Nette Framework. This is
- the only directory that you will need in order to deploy your application.
-
-- Nette-minified: contains Nette Framework source code compressed into single file.
-
-- client-side: this directory contains the JavaScript source codes.
-
-- API-reference: generated API documentation for the framework in HTML format. These
- files are build using Apidoc from the contents of the Nette directory.
-
-- examples: contains some Nette Framework demo applications.
-
-- sandbox: contains a pre-packaged Nette Framework project, basic configured
- structure for your application.
-
-- tests: contains Nette Framework unit tests and testing tool.
-
-- tools: contains supporting tools as a Requirements Checker, script that can check
- if your system meets the requirements for running Nette Framework.
-
-
-Getting started
----------------
-
-Probably the easiest way is to start with a Quick start tutorial:
-
-http://doc.nette.org/getting-started
-
-Have fun!
-
-
------
-
-homepage: http://nette.org
-repository: http://github.com/nette/nette

0 comments on commit 0615a2f

Please sign in to comment.